Missing node (SINGLE) can’t be displayed

I am getting the error “Missing node (SINGLE) can’t be displayed” on some nodes. For example: String Replacer, Column Filter, Reference Column Filter. I did not see this error in previous versions. I started getting this error with Knime 5. What could be the problem?

I’ve the same problem and unfortunately I haven’t been able to fix it yet. It’s very frustrating because you can’t keep working…

Hi both,

This seems to be an issue with the reworked configuration dialogs. Could you please share some more information with us so that we can look into this issue?

Best regards,

1 Like

Hi Stefan,

  1. String to Date&Time node works properly.
  2. Scatter Plot (JavaScript) works.
  3. OS is Windows 10
  4. I attached the KNIME log file

Thanks for your interest…
knime.log (138.7 KB)

Hey @fsaglam2002,

I am sorry to hear that you have problems and thanks for providing the logs and details.
Sadly I don’t see any helpful information about the “String Replacer” node in the logs. Would you be able to send me the workflow?


1 Like

Hello everyone,
I reverted to Knime 4.7 because the nodes I mentioned before were not functioning in Knime 5. In Knime 4.7, these nodes worked perfectly. To clarify this issue, I uninstalled Knime 4 from a different computer running Windows 10 Pro and installed Knime 5. Unfortunately, I am experiencing the same problems I reported earlier, including the Modern UI issue that I previously discussed on the forum. To aid in troubleshooting, I am including log records, the Knime Console, Error Log, and the workflow file.
Additionally, I have identified the following nodes that exhibit the same issue over time:
Problematic Nodes:

  • Column Renamer
  • Reference Column Filter
  • String Replacer
  • String To Number
  • Column Filter
  • Unpivot
    By the way, “String to Date & Time” and “Scatter Plot (JavaScript)” nodes are working correctly.
    Thank you for your help. Best regards.
    Eror Log.log (16.3 KB)
    Knime log.txt (24.9 KB)
    Knime_Console.txt (2.0 KB)
    missig node.knwf (19.9 KB)

Hi @k1000,

as a workaround (until we fixed the problem on our side) could you please try the following:
Add the line osgi.nl=en_US to your <knime-installation-directory>/configuration/config.ini?


Hi hornm
Thank you for your help. I tried this. Both problems I mentioned here were solved (Missing node (SINGLE) can’t be displayed; Repository is empty in Modern UI and workflow from Knime 4 does not open in new interface). Now I can run the program. I am so happy now.

I hope the problem will be solved as soon as possible.

Thank you again for your help and support.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.