ModuleNotFoundError: No module named 'asammdf'

Hello, I am new to KNIME.
I am not able to import any MDF file including .dat, .log and .mdf in Knime Analytics platform V4.4.2.
Below is the error when I try to open a mdf file.
Can anyone please help ?
Thank you in advance.

"Log file is located at: C:\Users\djdev\knime-workspace.metadata\knime\knime.log
WARN MDF Reader 0:2 Please select an input MDF file.
ERROR MDF Reader 0:2 No module named ‘asammdf’
Traceback (most recent call last):
File “”, line 1, in
File “C:\Program Files\KNIME\configuration\org.eclipse.osgi\472\0.cp\py\mdf.py”, line 50, in
import asammdf as asam
ModuleNotFoundError: No module named ‘asammdf’

Just an Update to above query;
using KNIME MDF Integration available from - https://hub.knime.com/knime/extensions/org.knime.features.ext.mdf/latest

After following the instructions and adding manual extension in preferences_Install/Updates_Available software sites;
I get this error when I reload it :-

No repository found at https://kni.me/e/Ran78zcx6zCBvhz0.
No repository found at https://kni.me/e/Ran78zcx6zCBvhz0

Hi @DevenJ and welcome to the forum.

This particular node requires use of the KNIME Python integration, and in addition it requires that the asammdf library be installed in your Python environment.

Our documentation describes how you can install and set up the Python integration: https://docs.knime.com/2020-07/python_installation_guide/index.html

4 Likes

Hi @ScottF !
Thank you so much for quick response. I went through the link and steps, I just created new environment in the Python 3 (default) which was ‘base’ before and py3_knime now solved my issue.

Also the .dat (MDF) extension isn’t visible in folders when we browse with default MDF files but selecting all files allows to choose .dat from the folder and it is readable too.
.log, .dat, .mf4 and .mdf are all MDF formats but the file browser just shows (.mf2, .mf3, .mf4, .mdf) and we have to choose All files option to select other MDF formats.

Thank you !

2 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.