Mounting point - Connection to KNIME server

I am about to deploy my first local KNIME Workflow to the KNIME remote server.
I become this error trying to add KNIME Server/mounting point:
“ SocketTimeoutException”
(Authentication type option is disabled).

Additionally I need more info about proxy entries in network connections (manual/direct/native).
How they need to be configured in order to connect to the server? Any documentation/example regarding this?

Thanks in advance for your help.


1 Like

Hi @volsebna,

The general setup of the KNIME Server mountpoint in the KNIME Explorer is described here: KNIME Server User Guide

There is no explanation about how to configure the proxy so let me quickly explain the setup.

There are 3 different providers to choose from in File → Preferences → General → Network Connections:

  • Native: The default one that fetches the settings from the OS
  • Direct: All OS settings are ignored and no proxies are used at all
  • Manual: Manual configuration. Just fill in HTTP and HTTPS proxy settings, in addition SOCKS if needed. Also check which domains (enterprise internal network domains) should be bypassing the proxy.

If you don’t know your proxy settings you could first try to use the Native provider. If this fails and you are trying to connect to a KNIME Server in the same network domain as your client, try Direct as Active Provider. If this works and you need additional internet access you can ask your IT department to provide the needed proxy settings and switch to the Manual provider, adding all configuration and Hosts to bypass.

More information on how the Native Active Provider is getting its information can be found here.


1 Like

Hi @MichaelRespondek ,

thanks for your explanation.

The general setup user interface looks a little bit different in my KNIME Analytics platform, comparing the screenshot provided in User Guide. I do not have option to choose authentication type/user credentials.

Regarding proxy options I am trying to connect to a KNIME server which is not in the same network domain as my client. Which one native/direct/manual should be appropriate in this case?

Kind regards

If you have access to the Webportal, try to use the URL until the /knime part of it in the Server address field. First I would try to use http with port 8080 (default), afterwards https/port 8443 (default). If http is activated on the KNIME Server it could be easier to use this as no custom certificates (if configured) are needed to install.

The Authentication type selection is activated after the needed REST endpoint is found.

If you already know that you need a proxy to connect to the KNIME Server I would recommend to try it with the Native Provider.
You should ask your IT department for the right proxy settings for http and https (and if a certificate is needed to install) access if this still fails. These settings should then be configured for the manual provider.

Good luck,

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.