Moving average bug? MA somehow not applied to all columns?

Hi everyone,

I’m using the “Moving Average” node to calculate the average of the past 12 months. After controlling some numbers, I just realized that somehow the moving average calc is not applied to all my columns - i.e. 1) the “MA(ColName)” as header is not applied and 2) numbers are just taken over from the previous node without any calculation. This only applies to very few columns but it happens and I don’t see any pattern except that at least the 13 first cell values of the input are 0’s but values follow afterwards. Please find a screenshot attached: Screenshot

Is this a bug or am I aplying sth. wrong?
Any idea on how to solve this is highly appreciated!

Many thanks in advance for your support.
Isabell

Hi

May I ask you to provide screenshots of the input table and the node configurations as well?

Armin

1 Like

Hi Armin,

Thanks for your response. Please find the screenshots attached below.

Cheers,
Isabell


Input data:

Node structure:
Screenshot_Node%20structure

Node setting:

Are you sure the columns are included in the node configurations?
Because I cannot see those column names “013…” in the list.
Just make sure that those columns are included as well and let me know then I will investigate the problem as far as I can.

1 Like

Yes, sorry I just did a screenshot from the initial opening and just didn’t scroll down. In fact all my columns from the input node are included.

Is it possible for you to provide the workflow or this part of the workflow (including the data)?
I couldn’t reproduce the problem so maybe it can help.

1 Like

Ok, now it gets myteriously:

  • New workflow: I wanted to separate this part of the workflow to provide you wth the input data and the moving average node. There, the error does not occur!
  • Original workflow:
    In my original workflow it still didn’t work, also not after several resets.
    Now I just copied/pasted the node from my original workflow into the original workflow and let it run again --> now it works as it should be.

Sorry to waste your time for apparently nothing and thank you very much for your support, Armin!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.