Multiple file reader and writer

Hi @ScottF,
you have suggested a solution to read multiple files here
Concatenate data from multiple xls files - KNIME Analytics Platform - KNIME Community Forum
Can you please help me to find a solution also, to write multiple files at the end of analysis?
Once the files are uploaded and using the loop the are separately analyzed, they need to be saved separately as well.

Thank you for your help!

Hi @sherknime -

Maybe these two examples can get you started?


Thank you @ScottF, it helped. Now i got another problem.
My workflow is separates empty and not empty files. Empty files should be ignored while not empty files need to be recorded.
For some reason my workflow is ignoring 1st file and starts processing from 2nd, do you know the potential reason?

thank you

UPD: i think it is because of the loop end. it does not trigger the “excel writer” before it shifts the iteration.
If the loop end connected to the excel writer, then it stops looping once the “empty file” is identified.
How can i close the loop and still have the workflow filter empty and not empty files?

Hi @sherknime ,

As you have discovered, there isn’t a place to anchor the flow variable when the table is empty.

This is an example use case for the “NodePit Power nodes”(formerly the “NoOp” / “No operation” ) nodes.

You don’t need those nodes, but they do make life simple and their purpose is clearer. The alternative is is place any node that does nothing (or even does something that you can safely ignore) and then use the flow port from that node.

e.g. before installing “NoOp”, I regularly used Add Empty Rows in this scenario (and had my own component that wrapped it!).

Just configure it to Add “an additional” zero rows! :slight_smile:

e.g. Here is what the flow could look like using the alternative options:

Details below re Nodepit Powernodes, with thanks to @danielesser

Make sure you configure nodepit for your version of KNIME using the drop down on top right of the nodepit page


hi @takbb
Seems like a solution. Thx a lot

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.