Newly addedd driver not Appearing in Database drivers dropdown

I have added new Database driver in knime using preference->knime->databases Section. After adding, when i go to Database Connector Node's configuration. That newly added driver not appearing there. I refreshed and restart knime but not working. Driver is right becuase it was appearing and working and then i removed driver and add it again for some reason since then its not appearing in the available Database Driver's dropdown. How to solve please help.


I couldn't reproduce your problem with KNIME 3.1. Can you find an excpetion in the KNIME log which might cause this bevavior? To view the KNIME log open KNIME and go to View->Open KNIME log.

KNIME stores the preferences in the workspace folder. So as a workaround you can open KNIME with a new and empty workspace and then add the driver. If this works you can simply import your workflows from the old workspace via File->Import KNIME workflows and selecting the old workspace directory as the root directory to import.



Hello Tobias,

I've just installed a fresh new v3.1.1.v201601291159 instance and created a SQL2008-like driver definition in Preferences. The driver is the well known MS sqljdbc4.jar, the registration went fine. An oDBC system DSN can connect to MSSQL Instance (AdventureWorksDW2012).

I expected to find the driver class ( = driver name) in the pulldown box either on database connector or database reader. The only choices I got there are: sqlite, mysql ( 4 x) , vertica and postgresql.

The KNIME.log is nonsymtomatic, no exceptions whatsoever. Am I missing something when trying to define the node or new driver definition?

Cheers, Dimitri


Hello Dimitri,

I can not reproduce your problem. I have just installed the sqljdbc4.jar driver in KNIME via File->Preferences in the KNIME->Databases category and I can select as database driver in the Database Connector node.

The KNIME log should list which drivers are loaded and if they are loaded successfully. To find them search for DatabaseDriverLoader. For the SQL Server driver it should be similar to this entry:

2016-02-05 18:06:28,268 : DEBUG : main : DatabaseDriverLoader :  :  : Database driver loaded successful from file C:\KNIME\JDBC\ms sql server\sqljdbc4.jar. Driver info: Driver class name: major version: 4 minor version: 0 jdbc compliant: true




Hello Tobias,

I re-installed the latest version,now it works like a charm, thank you for the remark!


2016-02-15 00:02:08,287 : DEBUG : KNIME-Worker-3 : WorkflowFileStoreHandlerRepository : Database Reader : 0:1 : Adding handler 6c945f7b-97f7-474f-b0f5-ba83bb963c20 (Database Reader 0:1: <no directory>) - 1 in total
2016-02-15 00:02:08,288 : DEBUG : KNIME-Worker-3 : LocalNodeExecutionJob : Database Reader : 0:1 : Database Reader 0:1 Start execute
2016-02-15 00:02:08,290 : DEBUG : KNIME-Worker-3 : DatabaseDriverLoader : Database Reader : 0:1 : Database driver retrieved from driver map
2016-02-15 00:02:08,292 : DEBUG : pool-3-thread-2 : DatabaseConnectionSettings : Database Reader : 0:1 : Opening database connection to "jdbc:sqlserver://;databaseName=AdventureWorksDW2012"...
2016-02-15 00:02:09,082 : DEBUG : KNIME-Worker-3 : DBReaderImpl : Database Reader : 0:1 : Executing SQL statement as executeQuery: SELECT * FROM DimAccount
2016-02-15 00:02:09,180 : DEBUG : KNIME-Worker-3 : DBReaderImpl : Database Reader : 0:1 : Reading meta data from database ResultSet...
2016-02-15 00:02:09,184 : DEBUG : KNIME-Worker-3 : DBReaderImpl : Database Reader : 0:1 : Parsing database ResultSet...


I too have seen exactly the same symptoms as hassan. (Thanks to tobias.koetter for trying to reproduce hassan's problem).

When I search knime.log for "DatabaseDriverLoader" I see nothing -- I've tried restarting Knime multiple times, deleting and re-entering it multiple times, even creating a fresh workspace and creating it again. Each time I see no errors, nothing in knime.log, and nothing but the defaults within the Database Connector node.


In my case, I tried using Oracle 10, 11, and 12 connectors -- all of the versions I could find and try, and a few different combinations -- for exampel, I downloaded version 10's ojdbc14.jar from here:


Has anyone else had this problem and had no luck getting error messages out of it? Any other things we can try as workarounds?

Hello , have you solved this problem ?
I have the same here .

Hi there!

What KNIME version are you using? What driver is it about? Have you tried creating a new workspace and adding a driver in it?


So, very late to this party, but in case it helps anyone, I found that adding JDBC drivers didn’t work until I started KNIME in Admin mode (I’m on Windows 10). Once I did that and “touched” each of the drivers I had previously added, they registered correctly (and several in-built drivers suddenly appeared).