Node Configuration: Input field lag and odd UI

Hi,

the new UI applied to some nodes is causing several regressions. Two of which is are:

  1. The inout field upon hover turning gray indicating it’s disabled
  2. A significant delay when trying to click into an inout field

I have created a few tickets related to the new UI despite not having it enabled. Is there a way to ensure the new UI is not used et all?

Best
Mike

Hey Mike,

thanks for the feedback and I am sorry to hear that you have problems with the new dialogs. We have different styles for our input fields and the one you are seeing is the hovering state. I will take your feedback and check with our UX department. Here you can see a list of our states.


Regarding your second point can you give a little more information or share an example workflow, in which this is the case?

There is no possibility to prevent the use of the new dialogs as there are some nodes that don’t have a classic representation of the dialogs. I hope we can soon figure out your issues and convince you that the new dialogs are far better compared to the classic ones.

Greetings,
Daniel

1 Like

Hey @DanielBog,

Thanks for your feedback. I have submitted a few topics about the new dialogue amongst which are some regarding performance regressions in opening the modals and “lost” (well relocated) flow variable configuration but also missing tool tips.

I personally find the new dialogues, respectively the sudden rollout pretty much premature. Whilst they provide a polished look they make interaction with Knime substentially worse. Unless the modern UI is enabled, I’d not have expected any such sudden change to appear, though.

Knime 5.1, when it comes to UI, is not really an improvement of “quality of life” and stands in stark contrast to the professionallism Knime actually stands for. I’d really like to urge “you” to elaborate about possible measures to ensure a good UI quality. Maybe a post-rollout poll in the community or some sort of sentiment analysis of the recent posts about 5.1 might provide more insights. Developing such a complex application certainly isn’t that easy but given the passion of others and mine, I strongly beleive the voices of the community should be heard about this.

Best
Mike

2 Likes

Hey @mwiegand,

There are definitely valuable points in your posts. The community will always be heard from our side which is why we have this amazing active forum. In my opinion the dialogs are a huge step forward, but I can understand why you don’t see this if you run into problems. Let me quickly summarise what you have mentioned so far:

  • Hover state looks like a disabled state
  • Performance issues in dialogs
  • Not entirely clear where and how to setup flow variables

Is there anything I am missing? Regarding flow variables we are already on it and I am happy to get your insights on the new approach as soon as they are ready.
Regarding the performance issues, I have never experienced these. Can you elaborate a bit on your OS and system setup?

Greetings,
Daniel

1 Like

Hey @mwiegand,

with 5.2 we did some major performance improvements to the dialog and the input lag should now be gone. Would be great if you could confirm that this is also the case for your problem.

Greetings,
Daniel

1 Like