NullPointerException while Pivoting


After running a GroupBy, I am performing a Pivoting function.  I  have about 85,000 rows in the GroupBy table.  After completing 41% it comes back with "Execute failed: ("NullPointerException"): null".  I have read through the forum and my File store chunk size is 400000.  I have tried to "Keep only small tables in memory" and also :"Write tables to disc".  What else can I look at?  This workflow works using different text, just not this particular text.  Any assistance would be appreciated.


Do you have some missing values in your table that are maybe not being handled correctly? 

Any chance we can see an example demonstrating the problem?


On the Pivots tab I have the "Ignore missing values" box checked.  I also have the maximum unique values per group set to 10,000.  Shouldn't that take care of the missing value issue? 

Well anyways, nullpointer:null isn't a very impressive error message.  If we can find the cause of the problem, we should be able to fix it fairly quickly (and maybe find a workaround as well).



I have zipped the workflow file and it is too big to load here.  Any suggestions?



How big is it?  Could something like google drive, or dropbox work?



The file is really big.  However, the problem is user error.  Instead of pivoting on thread title where I have lots of threads (30,000+)  that I want a sentiment analysis, I was pivoting on forum title, which was trying to give me the overall sentiment of the whole forum.  I am rerunning using post thread.  I should know tomorrow if it worked.



So, I made changes to the workflow which I thought would work.  They don't.  It still stops at 41% and gives me the same error.  

Here is a link to the workflow on dropbox.  Any help would be appreciated.  Hopefully it is not something really simple that I should have seen.