One to Many node doesn't respect Row Filter?

Hi,
I hope I’m overlooking something very simple at the end of a long day.

  1. Workflow
    image

  2. Data set:
    image

  3. Set row filter:

  4. Filtered table:
    image

  5. One to Many still creates a column with a value that no longer exists:
    image

I’ve placed a Cache node between the Row Filter and One to Many, but it doesn’t help. Am I overlooking something very simple?

Hi @Snowy,

The phenomenon you’ve described is definitely mysterious and weird.

Couple of weeks ago I was solving an issue. What helped me back then was Domain Calculator node which somehow updates how KNIME internally represents the table. It’s magic but it works.

I’ve tried introducing the Domain Calculator node to your workflow. And you’ll be surprised, I got rid of the non-existing value you complained about. Let’s have a look:

Regards, Jan

5 Likes

Hi there!

wouldn’t really call it “mysterious and weird” although can be perceived as such when first occurred. So after you filtered your data if you check Spec tab of Row Filter node you will still see there is ERROR! value listed under Group column meaning it is still part of (column) domain. Some nodes (One to Many included) take values from Domain and in such cases you should use above mentioned Domain Calculator node to refresh domain.

Hope this helps!

Br,
Ivan

1 Like

Thank you to you both @ipazin @jan_lender for your solution. This does indeed work.

I do wonder if there’s a better way to implement the One to Many node. While there may be a technical reason why it was implemented to take values from Domain, as a user it’s still not intuitive.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.