One2Many column: * has no possible values


I am having trouble with the following 2 errors:

1: “WARN One2Many column: * has no possible values”

I am getting this error when I am trying to use the One2Many node to convert the nominal column to multiple boolean columns. I do have a Domain Calculator & the Rename node before the One2Many node to check whether all the data is being imported fine & has the right Type.

Also the column does have valid values for most of the rows but there are rows where the value is missing for the column. Is Missing Value the problem? and how to fix it.

2: “ERROR FilteredClassifier Execute failed: IllegalArgumentException in Weka during training. Please verify your settings. A nominal attribute (*) cannot have duplicate labels (’(0.00043-0.00043]’).”

If I run the pipeline without the One2Many & with a Filtered Classifier with InfoGainRatioEval based top 100 feature selection & Naive Bayes classifier then it gives the above mentioned error. If I run the pipeline (w/o One2Many) directly with just a Naive Bayes model it runs fine. I know that I dont need to convert One2Many for Naive Bayes but I want to run SVM models & thats why the first error.

Help is greatly appreciated. I am new to the platform but I would like give my sincere compliments for developing this much needed platform for Large datasets.


Dear Wolf,

Can you please check if the output of the Domain Calculator contains nominal values for column “"?
(Right-click on the outport, select “Output data”, then switch to the second tab “Spec” of the outport view: the nominal values should be listed there under column "
Is it possible that your column “*” contains more than 60 different nominal values? Then you need to uncheck the checkbox “Restrict number of possible values” within the DomainCalculator dialog.
Does that solve your problem?


Dear Fabian,
Thanks for the response & the tip about the Domain Calculator. I added the node to the workflow & it is showing the data properly with the expected number of string values. I do have more than 60 different nominals so I did uncheck the checkbox “Restrict number of possible values” within the DomainCalculator dialog but still it is showing the same error.

1:Could it be a problem with some missing values (though i understand form the One2Many node description that it is able to handle missing values by not assigning ‘1’ to any column_value.
2: Are there any reserved characters like ‘*’, ‘&’ that can create problems in these transformations. (In most of the columns, that I am observing the error in, there are no such special characters).

I have also installed the latest KNIME version but the error still remains.


I also have encountered this problem.  I attached the 'Domain Calculator' node  and everything now works fine, but why is this needed?  This is just another node that is cluttering up my workflow.  Is it not possible for the 'One2Many' node in future to accept a table with more than 60 different strings.  One of the most annoying things about KNIME is that the error messages do not make sense. e.g.  'Column2 has no possible values'  is really unhelpful as I now for a fact the table does contain data in column2.


In KNIME, a data table consists of meta (column) data where for each column we provide additional information, such as lower/upper bound and what we call possible or nominal values. This information is part of the domain and can be (re-)calculated in the Domain Calculator. The defaults are 60 possible/nominal values, if more than 60 different values are in your data, the domain does not store these values. This is the point where you need this famous node.