Oracle JDBC - application dosent save path to it.

#1

Hello.

I can’t solve my problem. After every Knime restart I have to manualy set once again path to oracle jdbc in preferences -> Knime -> Database.

Anyone experienced the same issue that I have or know how to deal with it? :frowning:

0 Likes

#2

Hi there @theTigger,

only Oracle driver? When you start KNIME in log file (…\knime-workspace.metadata\knime\knime.log) should be info about (un)loaded drivers. Can you check there what is logged for Oracle driver, if anything?

And what KNIME version are you using?

Br,
Ivan

0 Likes

#3

Only for Oracle driver. Knime version 3.7.2.

2019-12-03 12:18:25,377 : DEBUG : main : %J : DatabaseConnectionSettings :  :  : Database concurrency (sync via database connection) is true.
2019-12-03 12:18:25,377 : DEBUG : main : %J : KNIMECorePlugin :  :  : Setting KNIME max thread count to 12
2019-12-03 12:18:25,393 : DEBUG : main : %J : KNIMECorePlugin :  :  : Setting KNIME temp dir to "D:\KnimeTemp"
2019-12-03 12:18:25,502 : INFO  : main : %J : KNIMECorePlugin :  :  : Setting console view log level to WARN
2019-12-03 12:18:25,502 : DEBUG : main : %J : KnimeEncryption :  :  : Replacing current encryption key supplier "null" with this new one "org.knime.workbench.core.EclipseEncryptionKeySupplier@49dce561".
2019-12-03 12:18:26,329 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Could not load JDBC ODBC driver class 'sun.jdbc.odbc.JdbcOdbcDriver'. Class has been removed in Java 8.
2019-12-03 12:18:26,360 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Load driver from file: C:\Program Files\KNIME\plugins\org.knime.database.connectors_3.7.0.v201808081048\lib\jtds-1.3.1.jar
2019-12-03 12:18:26,407 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Database driver net.sourceforge.jtds.jdbc.Driver loaded successful from file C:\Program Files\KNIME\plugins\org.knime.database.connectors_3.7.0.v201808081048\lib\jtds-1.3.1.jar. Driver info: Driver class name: net.sourceforge.jtds.jdbc.Driver major version: 1 minor version: 3 jdbc compliant: false
2019-12-03 12:18:26,407 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Adding driver to buildin map: net.sourceforge.jtds.jdbc.Driver
2019-12-03 12:18:26,532 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Load driver from file: C:\Program Files\KNIME\plugins\org.knime.database.connectors_3.7.0.v201808081048\lib\postgresql-9.4-1201.jdbc41.jar
2019-12-03 12:18:26,563 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Database driver org.postgresql.Driver loaded successful from file C:\Program Files\KNIME\plugins\org.knime.database.connectors_3.7.0.v201808081048\lib\postgresql-9.4-1201.jdbc41.jar. Driver info: Driver class name: org.postgresql.Driver major version: 9 minor version: 4 jdbc compliant: false
2019-12-03 12:18:26,563 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Adding driver to buildin map: org.postgresql.Driver
2019-12-03 12:18:26,875 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Load driver from file: D:\Microsoft JDBC Driver 6.0 for SQL Server\sqljdbc_6.0\enu\jre8\sqljdbc42.jar
2019-12-03 12:18:27,124 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Database driver com.microsoft.sqlserver.jdbc.SQLServerDriver loaded successful from file D:\Microsoft JDBC Driver 6.0 for SQL Server\sqljdbc_6.0\enu\jre8\sqljdbc42.jar. Driver info: Driver class name: com.microsoft.sqlserver.jdbc.SQLServerDriver major version: 6 minor version: 0 jdbc compliant: true
2019-12-03 12:18:27,124 : DEBUG : main : %J : DatabaseDriverLoader :  :  : Adding driver to user map: com.microsoft.sqlserver.jdbc.SQLServerDriver. Files: [file:/D:/Microsoft%20JDBC%20Driver%206.0%20for%20SQL%20Server/sqljdbc_6.0/enu/jre8/sqljdbc42.jar]
2019-12-03 12:18:27,374 : DEBUG : main : %J : DatabaseConnectionSettings :  :  : Settings database timeout to 30 seconds

I tested earlier ojdbc v10 and ojdbc v7. The second one worked, that’s why I’m using it.

0 Likes

#4

Hi there @theTigger,

tnx for log but nothing about Oracle driver. Additionally you can check log after you add driver…

Have you tried changing directory?

In general KNIME runs with Java 8 so suggestion is to use the ojdbc8.jar.

Br,
Ivan

0 Likes

#5

Hello,

I will try to use Java 8, then I’m gonna change directory. If this won’t solve the problem, I will upload my whole log.

Thank you for the reply.

0 Likes

#6

Hi there,

sure. Give it a try and let us know how it went. If log contains sensitive information don’t attach it here. Rather I will send you a PM where you can respond and attach log file.

Br,
Ivan

0 Likes