Partial knime execution errors out in batch mode with dynamic csv load

Hi Everyone,

I am an intermediate knime user and have worked with batch execution mode of knime as well. I am facing a really strange issue. Hope someone could help!

I have developed a workflow which is supposed to pick up url or location from the ‘List files’ output and loop through all the csvs in the folder.
I am able to run this workflow from knime platform. However, if I execute the same from Batch method, it runs partially till the ‘Table Row to variable loop start’ and errors out thereafter.

I noticed this as a warning on initially loading the workflow - which is fine. However, the run is expected to go through fine.

Another strange question - why does it leave the workflow in partially executed state when I have explicitly mentioned the ‘nosave’ option. My batch file content is as follows :

“C:/Program Files/KNIME/knime.exe” -nosave -reset -nosplash -application --launcher.suppressErrors org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“E:/GF-71 digital dashboard/KNIME/Knime-workspace/R101”

Any help or leads would be appreciated! Thanks in advance…

Hi there!

What is error you get? The batch process runs on same system/environment?

Br,
Ivan

  1. There is no error. It simply leaves the workflow in partially executed state at the step of looping through the csvs

image

  1. Yes, the batch process runs on the same system

Hi!

So the message from batch (command line) is that the workflow is successfully executed? And how do you see that the workflow is partially executed? In above picture there are no executed nodes…

Br,
Ivan

Yes, batch file runs successfully.

Sorry for the confusion, in the picture I just wanted to show the failure node ‘CSV Reader’.

After the batch runs successfully, I open the workflow to see that the workflow is partially executed (all tools till the ‘variable loop start’ turn green).

Hi!

The error is shown because the input location in CSV Reader is controlled by flow variable so it is actually not an error.

As I can see from your batch call you are not using -consoleLog option. If I may ask how do you know that workflow is successfully executed? Also maybe your workflow is partially saved before you start execution…

I have tried your example (using only the first couple of nodes) and everything runs ok… I can share it you want to try it.

Br,
Ivan

1 Like

Thanks Ivan. Not sure what the issue was - but it runs ok now. Thanks for supporting :slight_smile:

2 Likes

Cool :smiley:
Ivan