Password warning when opening GET endpoint without authentication

Hi all!

I have developed a component and example workflow including a GET Request endpoint making a call to a public REST endpoint so NO authentication is configured.

Everytime I open up KNIME I get this warning now:

WARN LoadWorkflowRunnable Status: Warning: GET Request 0:3:0:1
WARN LoadWorkflowRunnable Status: Warning: Node stores passwords in its configuration. The workflow was saved by an installation, which doesn’t store passwords (as per “knime.settings.passwords.forbidden” system property). Node probably needs to be reconfigured.

The components are meant to be shared with the community, so I cannot just change my system property the way I want to. How can I silence this warning otherwise? I saw a similar issue on DB password handling and back at the time it was a KNIME bug.

Thanks in advance for your help.

Peter Schmidtke

1 Like

Hi Peter,

This is known and developers are working to fix it.
(Internal reference AP-15885)

Best,
Temesgen

5 Likes