Possible bug when selecting / unselecting MountID in Preferences?

Hello,

When I go to File → Preferences → KNIME Explorer and I select or unselect (ticking the box) a MountID (for example LOCAL, EXAMPLES, My-KNIME-Hub) the changes are not correctly applied.

To be precise, the changes are saved when you unselect a MountID. But, if you want to select again a MountID, the changes are not saved. So I am unable to work with the MountIDs that I have unselected previously.

In my case, I have unselected LOCAL & My-KNIME-Hub for experimentation purposes and now I cannot undo my action. Meaning that LOCAL and My-KNIME-Hub do not appear anymore in the KNIME Explorer. I have tried to selected → Apply and Close, and nothing happens.

Any recommendation about how to proceed? I have restarted KNIME, the client, etc. And nothing. It is quite critical because currently I am unable to use KNIME with my LOCAL MountID. I can only use the EXAMPLES MountID because is the only one I have not unselected previously.

Thank you!

Hello,

Can you confirm - is this occurring on the latest version (4.5.2) or on a previous version?

Thank you,
Nickolaus

Hello @mdlhv ,

I tested this in the latest AP 4.5.2.

Repro steps:

  • File>Preferences>KNIME Explorer;
  • unselect My-KNIME-Hub and LOCAL.
  • click apply; observe that they are removed from KNIME Explorer window.
  • click apply and close.
  • File>Preferences>KNIME Explorer
  • select My-KNIME-Hub and LOCAL.
  • click apply; observe that they reappear in KNIME Explorer window.
  • click apply and close.
  • Open a workflow from the LOCAL repo.

In the end, I was unable to reproduce your issue.

  • Please verify which version you are on;
  • if it is the latest, please confirm if you upgraded from a previous version via File>Update KNIME, or if you unzipped/installed via other means.

You may wish to download the zip archive from [1] and unzip it in a separate directory and test if you get the same results there, or if you are unable to repro as I was.

If your main install is on 4.5.2 and a fresh unzip copy doesn’t repro then maybe there is an issue with the particular installation (thus reinstallation may resolve.)

I look forward to your update.

Thank you,
Nickolaus

[1] Download KNIME Analytics Platform | KNIME

Hi NDekay,

Thanks for your answer.

It happened in the version 4.5.1.

The way I solved it was by:

  • Exporting the preferences
  • Opening the exported file with a text editor
  • Changing the values of the MountID that didn’t appear from False to True
  • Saved the changes
  • Imported the preferences

And everything worked again. I hope this trick can help other users that might read this post in the future.

Regards.

Hello @mdlhv ,

Clever solution. I’ll see about testing further to see what might put the preferences into a state where it doesn’t allow the mountid preferences to be updated, but I’m glad that you were able to resolve it through a manual export/tweak/reload of prefs.

Regards,
Nickolaus

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.