POST Node body needs (form-data or raw or binary) type

How can I achieve this request In Post knime Node. or with HTTPretriever node
PS: the Heders request: is Content-Type application/x-www-form-urlencoded


my request work well with postman but with knime node, i didn’t find a solution how to make it
please I’m looking for your suggestion

Thank you

Hi Mokrani,

In your screenshot, you’re using multipart form-data. That is currently not supported by the KNIME REST nodes. Still, if you rather need x-www-form-urlencoded like you said, you can make it work by converting the string you pass to the body to be url-encoded. Please see here for an example how this can be done: https://www.knime.com/nodeguide/data-access/rest-web-services/sugarcrm-meets-salesforce

It’s in the “Parameter input” metanode of the Salesforce part.

Cheers,
Roland

1 Like

based on the workflow of salesforce part i tried to do the same thing to my URL Rest bust its the same issue i cant get my final Result
Please find attached a screenshot of my workflow and POSTMAN Result

Have you tried this also in the POST Request node? Please note that you also need to set the Content-Type in the request header, see here:

yes the header Request is application/x-www-form-urlencoded and still the smae problem

Problem solved by sending the cookie of the login page URL to the send second httpRetriever that contains the standards URL

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.