PostgreSQL connection fails in Webportal but works in analytics platform

Hello everyone,

I'm using KNIME Analytics Platform 3.4.1 and KNIME Server 4.5.0. I have a workflow that looks like this:

As you can see, all nodes are green. The connection and reading from the database work perfectly in the analytics platform. The configuration of the PostgreSQL Connector looks like this:

When I deploy this to the server, if I select the checkbox "Reset workflow(s) before upload" (to ensure a fresh connection and read), the connection fails in the server. This is how uploading looks like:

This is the error I get in the webportal when I try to execute the workflow:


NOTE: If I don't check the "Reset Workflow(s) before upload" checkbox, the workflow executes successfully in the webportal but I assume I don't have a fresh connection and read to the database.

ANOTHER NOTE: I also tried using the Database Table Connector node, selecting the driver "org.postgresql.Driver" and it is the same issue, it works in the platform but not in the webportal when selecting the checkbox.

Can anybody please help me solve this?...Thanks in advance!




It may be possible that Postgres doesn't allow connections from the KNIME Server. Check the settings in pg_hba.conf.

Hi Thor,

thanks for your answer.

What should I check for, exactly?...What exactly should I change in pg_hba.conf in order to allow it?

That depends on your internal setup. But essentially you have to check that Postres allows connection from the server's IP address to your database with the username your are using. If you don't know what I'm talking about then please ask your database administrator.

Thanks for your answer. Although I haven't checked this file because I have no access to the server where this database is, (I will have access soon), I just realized that the server didn't have preferences configured with the file "preferences.epf".

I just added the file with the path to the database drivers. Still is not working.

My question is, if this file was not there, then is this file relevant at all for the problem I'm having?

The PostgreSQL driver is shipped with the node therefore you don't need a preferences file for it. And the connection to the database kind of works as you can see in the error message. It's the authentication that doesn't work and my suspicion is that it's got something to to with the permissions on the database. You may find more information in the KNIME Server's log file and also in PostgreSQL's log file.


The problem was a mismatch in the versions of which the workflow was created and the version of the executor in the server..

Workflow created with KNIME Analytics platform 3.4.1 and this was deployed to a server with executor 3.4.0. Apparently 3.4.1 is encrypting the password to the connections with the database and 3.4.0 doesn't.

Now I've updated both, my client and the server to 3.4.2 and it works.

A post was split to a new topic: Connect to a neteeza IBM DB