Preferences DB Connection error

Hi, I have installed KNIME sever and can get jobs to schedule but when I try to schedule a DB Connection node I am getting the following error:
Database Connector 4:5 - ERROR: Execute failed: Could not create connection to database: Could not find driver class: oracle.jdbc.driver.OracleDriver

I have exported the preferences.epf file to the correct server folder and then also tried a trimmed down version of the preferences file with only the driver location included. Can I send someone the log file for a quick look through? It is probably something simple I am missing!

Thanks in advance

I should have mentioned the Knime server is installed on a Windows machine. I’ve followed the instructional step on the admin guide without success…

have you tried these steps (since the message says it cannot find a driver):

  • access the DB from the ‘local’ (that is not the server) KNIME
  • run a workflow from the server without automation/scheduling
  • (with scheduling you get the problems you mentioned)

Are you able to access the DB from this specific machine by any other means than KNIME.

Hi. Yes, the workflow executes correctly from the local instance of Knime. It is only when I try to schedule the workflow from the server that I get the error as described. I can post the snippet of the server logs if that would help to troubleshoot further?


Should have included that I can access this dB through other apps from knime on the machine the server is installed.

Maybe you could send the question to the KNIME support they might be able to interpret the LOG. I know the KNIME server from a quite large enterprise environment and know that our IT guys worked hard on a bunch of permissions that were necessary to be able to let KNIME server do its magic. For obvious security reasons.

Are you able to configure the DB server yourself. You might clear your LOG and try again to first run the DB query on the KNIME server without scheduling and then with scheduling. We might try to look at the LOG (cannot promise anything). And also make sure the log does not contain any sensible informations.

Just wanted to check that you restarted the KNIME Executor (easiest done by restarting the whole KNIME Server) after making the changes to the preferences.epf.

The loaded preferences should show up in /runtime/runtime-50*/.metadata/knime/knime.log


Hi. Thanks for your responses. Looks like there was an instance of KNIME running in the background even though it wasn’t visually apparent, so when I was restarting the server the new preferences were not being picked up. Anyway once I killed that session of KNIME and restarted the server the updated preferences were picked up and the drivers can now be accessed from the server.

Thanks again for your help.