Problem opening a workflow

Hi all,

Before v3.7, I didn’t have a problem, but I have been suffering A LOT of problems with KNIME lately (v.3.7.1). It freezes frequently and usually, I have to force quit it and reopen. This morning after 50h of processing one of my workflows, KNIME failed again and I had to quit it. But this was not my main problems, because there was no way to open again this wf!! When I tried to do it, KNIME stood for hours in the attached screenshot window. Cancel button, of course, didn’t work also.


Finally, I was able to export and reimport my own wf, and I suppose that the reset was done before exporting solved the problem.

I don’t know how I can help you to identify and solve this type of problems for future releases, but please ask me anything you want to know. I can send you my exported (and reset) wf, but it doesn’t have any data, and of course, I cannot provide original wf with data due to size neither the data source due to GRPD.



There is a patch jar for Windows 3.7.1 (until 3.7.2 is released which will contain this fix) - please see here Workflow Freeze

1 Like

Thank you so much. I have just download and applied the patch.

In any case, my old wf still cannot be opened.

When the old WF fails to open, do you see odd windowing display (for example, if you dragged the dialog across the main window, does it not redraw correctly?)

Also, is there anything in the KNIME log file (in your workspace’s .metadata/knime/ directory) that hints at an error? (perhaps quit KNIME, delete the log file, start KNIME and then try to load the WF)

Also, also, if you haven’t altered the -Xmx... argument in your knime.ini file (in the same directory as your KNIME executable,) could you try giving it a more memory (for example -Xmx4g would give it 4 gigabytes; -Xmx3300m would give it 3300 megabytes, etc)?