problem when unzipping a ".bin" file


I’d like to extract an embedding object from a lot of Word documents. Before doing a loop I try to make a workflow with 1 file. To realize it, I unzip (with "unzip files" node) the .doc or .docx and then I select the file I need. This file is a .bin which have to be unzip to obtain the object I need.

Currently I can isolate the .bin file but when I try to unzip it, the "unzip files" node doesn’t afford the whole files. It appears that I only obtain the starting file with no extension. I tried to move the .bin file and change its extension to .zip but "unzip files" node gave the same result. However if I try to unzip the same file (.zip, .bin or without extension) manually (eg with 7zip) I obtain the files I’m looking for…

Any idea to make it work ?

Thanks for the help.

Hi ChristopheN, 

I can suggest that it's a limitation of the Java library we use for the implementation of the Unzip Files node. 

However, you could try to use a command line command to unzip a batch of files with the following command:


"C:\Program Files\7-Zip\7z.exe" e *.zip

 considering 7zip is installed in C:\Program Files\7-Zip location. 






Hi Anna,

Many thanks for your answer. I came to the same conclusion.
It also happens with ".doc" files which can't be unzipped with the node, while it works fine with ".docx".

I was searching to integrate 7zip in the workflow but still had no real solution, so I'm glad somebody offer me an idea, thanks !

I'm wondering how insert it direclty in the workflow, maybe with java ? But don't know java at all...

Best regards,


You can try also IZARC universal archiver. It has a portable version and you do not need to install it.