Problem with File Reader Node and Flow Variables

I developed a workflow to get the data from several CSV files. Essentially, I use string input to enter the entity name and the input file name, then I contstruct a file url for File Reader and it runs okay the first time. Then, when I change the variables, I run into a problem. Mainly, somehow the File Reader still has previous table's information.


have you made sure that the File Reader URL is actually controlled by a flow variable? For further help I would need an example workflow or at least a screenshot to see what might be the issue.

Here is the workfrlow. Basically, I have several tables (entities). I get new parts periodically. So, I have to go in and extract new parts. I set it up so that I just change a couple of variables and the rest is done.

Hi, thanks for uploading the workflow. However, without playing around with actual data I can't really figure out what is the problem - the configurations seem fine (although there is a weird behavior in that the KNIME GUI shows incorrect choices for the variables which are replaced by the string manipulation nodes - but this seems to be a bug which is not affecting the backend of the workflow). The only idea I currently have is not to overwrite the flow variables in the various nodes but to create a new flow variable in each step. Maybe this will help in debugging the workflow. 

Thank you. I'll try creating creating new variables at each step and will let you know if it works. However, I think the problem is something else there. The problem is the following:

I have several entities for which I get new parts periodically. So, I created the "Appender" function. In the back end, I have 2 folders: Current and Increment. So, I tell the Appender the Entity Name and it goes into those folders, picks the current file and the increment file for that entity, and then appends the increment to the current file. It works fine when I do it the first time. However, when I enter the name of the next entity, it stops at the File Reader note with an error. When I look at the output, and then at table properties, it still has the previous entity's headers there. When I open the node, wait for a second for the red text to go away, and then click OK, the error goes away and I am able to execute all the way. However, then, when I start over with the next entity, I run into the same problem until I open the File Reader node and click OK.

Hi i am defining flow variables in Java edit variable node and using them in further nodes. They are available there and working finely but when we save and reopen the workflow flow variable tab get reset. Anybody having workaround for the same ?