Problem with Pivoting Node


I am facing a similar problem -

and cannot see the pattern aggregator option as described earlier

Please suggest.

Hi @RajiMouli2 -

I created a new topic for your question, since 1) the topic you were responding to was 8 years old, and 2) that topic was about the GroupBy node, where here you are using Pivoting.

Can you please upload a workflow showing what you’ve tried so far, along with some sample input data, and what you want the output data to look like? Then maybe someone can better assist you.


Hi @RajiMouli2

I can recreate a similar error to you:

I did this by attaching a data table to the pivoting node, and configuring it, but then I modified my workflow so that the column (in my case “Cluster Membership” which for demo purposes I renamed to “Cluster Membership2”) no longer exists.

When I went back into the Pivoting node, it is showing a red line around the column name because it does not know this Column, and the message is simply saying that it is misconfigured.

So to me it looks like you have modified the data flow after configuring this node, and you need to now delete the current aggregation setting, and then specify the correct column name that you wish to aggregate.

If this still doesn’t resolve it, then as @ScottF says, uploading sample data/workflow will be necessary for somebody to assist further.


Thanks a lot, this worked

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.