Problem with SegmentFeature Node +Slice loop

Hi all,

I am using the Segement Feature Node to extract NumPix+Circularity of labeled segments in time lapse data (1channel, 200 time points). At the end I want to measure size+circularity of all nuclei at each time point. The Segment Feature Node works but needs >12min for a stack with 200 slices (timepoints) containing only ~100,000 labels which is far too slow ... For the same data, ImageJ Particle Analyzer returns a result table with ~100,000 rows in <10sec.

We have Knime version 2.11.2 (stable+ nightly built, heap space is set to 55GB) and in both the Segment Feature node is very slow.

To speed up the analysis, I tried as well the Slice loop and got the following error message:

ERROR     Slice Loop End                     Execute failed: Interval must fit into src in SubsetViews.subsetView(...)

Do I use the wrong settings? I attached an example with 10 slices/timepoints and would be happy about any suggestions or comments! 

Thanks!

Best,

Julia

Hi Julia,

concerning the SliceLoopStart / End Problem: Try to use a regular "Loop End" instead of the "Slice Loop End", as you don't want to reassemble the bitmask and just collect the output row-wise.

Concerning the speed of the "Segment Feature Node": We are aware of the fact, that this node is way to slow and we are working on a new version which is nearly ready (on Monday it should be available in our nightly-build). Anyway, 12min vs. < 10sec is really, really strange. I will see what I can do over the weekend.

Thanks for the bug report, this is really amazing feedback!

Christian

 

One idea I have which might increase your performance:

In KNIME can you go on File -> Preferences -> KNIME -> Image Processing Plugin. There you have the option to set "The maximum file size in MB". Could you set this to e.g. 100 and test if your node runs faster afterwards?

Hi Christian,

thanks for the very fast reply!

The slice loop worked with the regular loop end!

Concerning the Segment Feuture node: Increasing the "Maximum file size" to 100 or 200MB in preferences reduced computation time from 12min to 8min for one time lapse. I am looking forward to the new version of the node!

Thanks again and have a nice weekend

Julia

 

 

 

 

 

 

 

If you put it to 2000MB, does it further increase your runtime?

 

Hi Christian,

if I put it to 2000MB the run time stays more or less the same - 10min on my computer, 7min30s on the workstation.

Best,

Julia