problem with SSD

Hi, me and my collegues have last week add a SSD on ours pc and we installed knime in the SSD.

after the installation all three have the same problem, the process of the workflow has become very slow, and also there is often crash. what we can do to fix it? (before in the same pc with knime installed on the normal hard disk, the program works well).

we have just try to change the temp folder and put it on the normal hard disk but there is no improvment.

 

so there is some incopatibility beetween knime and the ssd? 

 

thank for the future help

Hi baarzo,

SSD should improve KNIME effieciency in general, so I wouldn't expect any issue here.

- Did you already try to increase the heap space memory? To do that, please follow the following instructions:

  1. In the KNIME installation directory there is a file called knime.ini (under Linux it might be .knime.ini; for MacOS: right click on KNIME.app, select "Show package contents", go to "/Contents/Eclipse/" and you should find a Knime.ini). Open the file,
  2. Find the entry -Xmx1024m and change it to -Xmx4g or higher (for example).

  3. (Re)start KNIME.

- Under workspace/.metadata/knime/nodeusage_3.0.json you can find some statistics related to the number of crashes that you encoutered. To check the number of launches and number of crashes just go at the bottom of the file where you will see sothing like that:

>     "launches":xxxx,

>     "crashes":x

Best,

Vincenzo

thanks Vincenzo we have already increse the heap sapce memory to 5Gb, my collegues to 4Gb but knime works slow for all.

I try to change the temp folder from SSD to HD but this improve a very little bit. So you can conform that SSD usually improve the performance of Knime, also we hoped the same.

from the nodeusage_3.0.json I have this statistics, i don't know if help:

    "uptime":12655746,
    "workflowsOpened":255,
    "remoteWorkflowsOpened":2,
    "launches":269,
    "timeSinceLastStart":368770,
    "crashes":21,
    "properlyShutDown":true

There will be other things that can slow the program?

 

Hi baarzo,

I would suggest you to check the following points:

  • Update KNIME Analytics Platform to the latest version. Yesterday, KNIME Analytics Platform 3.4 has been released.
  • Increase the heap space memory in the Knime.ini file 
  • Run the same workflow on other computers and check the difference in the time execution
  • increase the number of cells in memory, see our FAQ: https://tech.knime.org/faq#q18

If that still does not help to improve the speed of the execution of the workflows, please try with a new fresh installation.

Hope that helps,

Best,

Vincenzo

 

Hi

We have switched to SSD more than one year ago at the workplace.

At home I have-it for several years already 

It has been a huge improvment!

Your problem looks to be in hardware-controler /bios/OS-kenel settings, not Knime !

Try any other utility to benchmark your  HDD (SSD)

yes I think so that the problem is in ours pc, after the update of firmware of the SSD there was an improvements, but the workflow are yet slower than before add the SSD, I will use the tips of vincenzo, now I add this line

-Dorg.knime.container.cellsinmemory=1000

1000 is a good choise?

after the update of knime 3.4 it seems work fine now. maybe there was some problem in the previosly installation that was fixed with the installation of the new version

Hi baarzo,

Great that now everything works fine!

Best,

Vincenzo

finally we understand where there was a problem that the last update partially hide with the update 3.4.

 

The real problem was the antivirus that continuing scan what knime doing during the process, we put an exception for the workspace directory and now knime work well.

the bad luck was that we change the SSD at the same time of the antivirus and we did not thought that the problem was the antivirus.

hope that this experiece can help some others.