problem

dear all,

I have already installed rdkit and all nodes compare in my drop down list but from two days when i try to use rdkit nodes as molecule>rdkit compare

Could not load native RDKit library 

i have checed for update but no news. what can i have to do to solve the problem?

thanks

Which version of RDKit are you using, 1.0 or 1.1 (more exactly, which version of the org.rdkit.knime.types plugin)? There was a greater change yesterday that may cause problems. Which operating system are you using? Can you have a look in knime.log and post the full stack trace of the error?

dear

I0m using  the org.rdkit.knime.feature_1.0.0.0000991 the OS as indicate in log file is Win XP sp3

!SESSION 2011-05-31 12:04:24.163 -----------------------------------------------

eclipse.buildId=unknown

java.version=1.6.0_22

java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_GB

Command-line arguments:  -os win32 -ws win32 -arch x86 –clean

 

this is the message in log

!ENTRY org.rdkit.knime.types 4 0 2011-06-28 12:04:38.762

!MESSAGE Could not load native RDKit library

!STACK 0

java.lang.UnsatisfiedLinkError: C:\Documents and Settings\colace\Desktop\knime_2.3.4\plugins\org.rdkit.knime.bin.win32.x86_1.0.0.0000990\os\win32\x86\GraphMolWrap.dll: Can't find dependent libraries

                at java.lang.ClassLoader$NativeLibrary.load(Native Method)

                at java.lang.ClassLoader.loadLibrary0(Unknown Source)

                at java.lang.ClassLoader.loadLibrary(Unknown Source)

                at java.lang.Runtime.loadLibrary0(Unknown Source)

                at java.lang.System.loadLibrary(Unknown Source)

                at org.rdkit.knime.RDKitTypesPluginActivator.start(RDKitTypesPluginActivator.java:79)

                at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)

                at java.security.AccessController.doPrivileged(Native Method)

                at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)

                at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)

                at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)

                at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:284)

                at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)

                at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)

                at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)

                at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)

                at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)

                at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)

                at org.eclipse.osgi.internal.loader.SingleSourcePackage.loadClass(SingleSourcePackage.java:33)

                at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:466)

                at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)

                at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)

                at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)

                at java.lang.ClassLoader.loadClass(Unknown Source)

                at org.rdkit.knime.nodes.molecule2rdkit.Molecule2RDKitConverterNodeModel.configure(Molecule2RDKitConverterNodeModel.java:125)

                at org.knime.core.node.NodeModel.configure(NodeModel.java:953)

                at org.knime.core.node.NodeModel.configureModel(NodeModel.java:903)

                at org.knime.core.node.Node.configure(Node.java:1434)

                at org.knime.core.node.workflow.SingleNodeContainer.nodeConfigure(SingleNodeContainer.java:442)

                at org.knime.core.node.workflow.SingleNodeContainer.configure(SingleNodeContainer.java:363)

                at org.knime.core.node.workflow.WorkflowManager.configureSingleNodeContainer(WorkflowManager.java:3301)

                at org.knime.core.node.workflow.WorkflowManager.postLoad(WorkflowManager.java:4281)

                at org.knime.core.node.workflow.WorkflowManager.loadContent(WorkflowManager.java:4130)

                at org.knime.core.node.workflow.WorkflowManager.postLoad(WorkflowManager.java:4240)

                at org.knime.core.node.workflow.WorkflowManager.loadContent(WorkflowManager.java:4130)

                at org.knime.core.node.workflow.WorkflowManager.load(WorkflowManager.java:4031)

                at org.knime.core.node.workflow.WorkflowManager.loadProject(WorkflowManager.java:3830)

                at org.knime.workbench.editor2.LoadWorkflowRunnable.run(LoadWorkflowRunnable.java:158)

                at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464)

                at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372)

                at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507)

                at org.eclipse.ui.internal.progress.ProgressMonitorJobsDialog.run(ProgressMonitorJobsDialog.java:275)

                at org.eclipse.ui.internal.progress.ProgressManager$5.run(ProgressManager.java:960)

                at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)

                at org.eclipse.ui.internal.progress.ProgressManager.busyCursorWhile(ProgressManager.java:995)

                at org.eclipse.ui.internal.progress.ProgressManager.busyCursorWhile(ProgressManager.java:970)

                at org.knime.workbench.editor2.WorkflowEditor.setInput(WorkflowEditor.java:679)

                at org.knime.workbench.editor2.WorkflowEditor.init(WorkflowEditor.java:294)

                at org.eclipse.ui.internal.EditorManager.createSite(EditorManager.java:798)

                at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:647)

                at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:465)

                at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:595)

                at org.eclipse.ui.internal.EditorAreaHelper.setVisibleEditor(EditorAreaHelper.java:271)

                at org.eclipse.ui.internal.EditorManager.setVisibleEditor(EditorManager.java:1429)

                at org.eclipse.ui.internal.EditorManager$5.runWithException(EditorManager.java:942)

                at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)

                at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)

                at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)

                at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4041)

                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3660)

                at org.eclipse.ui.application.WorkbenchAdvisor.openWindows(WorkbenchAdvisor.java:803)

                at org.eclipse.ui.internal.Workbench$31.runWithException(Workbench.java:1567)

                at org.eclipse.ui.internal.StartupThreading$StartupRunnable.run(StartupThreading.java:31)

                at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)

                at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:134)

                at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4041)

                at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3660)

                at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2548)

                at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)

                at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)

                at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)

                at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)

                at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)

                at org.knime.product.rcp.KNIMEApplication.start(KNIMEApplication.java:95)

                at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)

                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)

                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)

                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)

                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

                at java.lang.reflect.Method.invoke(Unknown Source)

                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)

                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)

                at org.eclipse.equinox.launcher.Main.run(Main.java:1407)

I am also still using Windows XP and have been able to install the latest RDKit version (nightly build) into KNIME v2.3.4.

I have heard that 64bit Windows is not supported with RDKit. I dont know if this may affect any of you.

 

Simon.

I have the same problem with Win XP 32-bit and KNIME 2.3.4.

Yesterday's RDKit update (RDKit KNIME integration 1.1.0.0001001) caused this error to occur:

2011-06-29 11:29:53,623 DEBUG main Molecule to RDKit : Could not load native RDKit library
org.knime.core.node.InvalidSettingsException: Could not load native RDKit library
at org.rdkit.knime.RDKitTypesPluginActivator.checkErrorState(RDKitTypesPluginActivator.java:137)
at org.rdkit.knime.nodes.molecule2rdkit.Molecule2RDKitConverterNodeModel.configure(Molecule2RDKitConverterNodeModel.java:125)
at org.knime.core.node.NodeModel.configure(NodeModel.java:953)
at org.knime.core.node.NodeModel.configureModel(NodeModel.java:903)
at org.knime.core.node.Node.configure(Node.java:1434)

Any ideas? George

I am able to reproduce this on a computer different from the one I normally use to test the nodes. I will see if I can track down the problem and fix it (or at least propose a work-around).

Sorry for the inconvenience.

-greg

One thing that would be extremely helpful for tracking this problem down is if someone who is experiencing it could install the following package on their windows machine:

 

http://www.microsoft.com/download/en/details.aspx?id=5555

and see if the RDKit nodes work after that installation. Unfortunately, I cannot do this installation on the machine where I can reproduce the problems so I cannot test it myself.

-greg

Ok, I believe that I found a solution that does not require installing any additional files. It will be in tomorrow's (Friday's) nightly build.

Keeping my fingers crossed,

-greg

It turns out that the nightly builds run later than I thought. I made my changes in time to have them show up in today's build. If you update from the nightly build now, the RDKit nodes should work.

Sorry about the problems,

-greg

Dear Greg,

Semms that the problem is solved with your changes

thanks

Hi Greg,

Many thanks for this. I've got good news and bad news:

The good news is the RDKit nodes now work and I particularly like the new visualisation. Well done!

The bad news: After the updating RDKit, the MMP detector node suffers from a huge memory leak which make the node fail at some point when dealing with > 2K compounds.

This was certainly not the case before RDKit v2.0.

This has happened in the past but we managed to fix it by manually deleting the objects we created in the code (eg. mol.delete(), prods.delete(), etc.). Furthermore, as the MMP node uses code from your 1 component reaction node, I tried your node with 2K mol using this reaction SMARTS string: [*:1]!@!=!#[*:2]>>[*:1]-[*].[*:2]-[*] (effectively fragmenting all acyclic, single bonds). Looking at the system memory usage, it looks like there is a memory leak in your node too (about 500MB used) but at least your node manages to finish OK.

I'll look again at the code of the MMP node again and I'll come back to you (btw what is the difference between ROMol and RWMol???).

Regards,

George

George,

I don't see any leakage from the single-component reaction node. I just tried an example with your reaction applied to ~600 molecules. Though I get a lot of products (~22K), and consequently heavy memory usage. repeatedly resetting the node and running it again doesn't lead to an increase in memory use (as one would expect from a leak).

You definitely need to delete stuff in order to prevent memory growth; this seems to be an unfortunate consequence of the way the JNI wrappers work (my minimal understanding: java doesn't know how much memory the C++ code in the back is using and so it doesn't do GC when it should).

-greg

Hi Greg,

Thanks for the reply. I'll investigate further.

George