Problems connecting to SQL Server

Hello, 

I'm new to Knime and am having trouble connecting to SQL Server.

I think I have properly installed the jtds driver and copied the ntlmauth.dll to the appropriate folders as suggested elsewhere in the forum. 

However, I recieve the following error and seem to be at a dead end as I haven't been able to find any documentation explaining it: java.sql.SQLException: Network error IOException: Invalid argument: create

Can someone please explain this error to me?

I'm using a url in the form of jdbc:jtds:sqlserver://SERVER_IP:PORT/TABLE (where SERVER_IP:PORT and TABLE reference the actual values). I have gotten the same URL to work in RapidMiner on the same Windows 7 Pro PC, which leads me to think the url I'm using is valid. I'd much prefer to use Knime as it seems more intuitive to use.

Any help would be greatly appreciated. 
 
Thanks!
 

 

I'm using MS jdbc driver (http://msdn.microsoft.com/en-us/sqlserver/aa937724)

com.microsoft.sqlserver.jdc.SQLServerDriver

Setting URL to

jdbc:sqlserver://<HOST>:<PORT>;databaseName=<DATABASE>

Connecting to SQLServer 2008

Knime 2.3.4

Thanks bwilsonb

I wasn't aware there was a newer version of the Microsoft Driver.

I installed it as you suggested but now I'm getting a TimeOut Error instead.

I guess, either server and/or port are wrong or it's an firewall/proxy issue. Can you please check if you can access the database server? Are you using the correct URL as posted by bswilsonb.

After giving up for a while, I was able to get the jtds driver working using URL: jdbc:jtds:sqlserver://HOST:PORT/Table

Thanks for your help!

Hola buen dìa

Soy nueva en knime y tengo problemas en la conexion de esta herramienta a sql server 2012,

ya he instalado el driver el cual el sqljdbc4.jar y aun con eso tengo un error que es "Database Connector    Execute Failed: could not create connection to database: No settings available to create database connection"

la ruta que he utilizado para la conexion es:jdbc:sqlserver://<host>:<1433>/<database_name>

y la verdad no se a que se deba el error