Problems using Stacked Area Chart Node in knime 4.3.0

Using Stacked area chart I discovered the following issues

  1. The grid is still displayed even if I disable the grid.
  2. The last value on the x-axis is been displayed twice.

Will tooltip be available for basis method in coming releases?

Any suggestions on how to resolve these issues?

Hi @swaroop4593 and welcome to the forum.

Using a simple example workflow like this one ( I’m not able to replicate either problem you’re seeing - I can control the grid appearance, and I don’t see duplicate values on the x-axis.

Details on the three basis options are provided in the node description, although there currently isn’t a tooltip.

What version of KNIME are you using, and on what OS? Do you have a sample workflow handy that reproduces the problems?

Hello Scott, Thank you for responding.

I’m using Knime 4.3.0 and Mac OS Mojave version 10.14.6

Here is my sample workflow
sample_workflow.knwf (34.8 KB)
Please select “ALL” or “MESSAGE_4” option under Name Filter to reproduce the problem.

  • I also tried using the stacked area chart (plotly) instead. But couldn’t add custom colours to fill areas based on columns SENT & RECEIVED. Is there a way to do it?

  • and for representing curved edges, should I use custom scripting using generic javascript view node?
    sample workflow sample_workflow_plotly.knwf (31.6 KB)

Can you upload your sample_data.xlsx files as well? The workflows you posted have been reset. Thanks!

sample_data.xlsx (9.4 KB)

I’m still not able to reproduce your original problem, but I’m using Windows. I wonder if it’s an OS issue. My results below:

As for your second set of questions, offhand I don’t know the answers. Let me ask one of our developers to take a closer look.

Scott, I see in your result the last two values on the x-axis are repeating. That is the problem I’m taking about. (Date 2019-12-08 is missing from x-axis and Date 2020-01-12 repeated twice)
I actually see the grid re-appearing when you change the value in Filter by Value dropdown even when I disable the grid option.

:man_facepalming: You’re right of course about the repetition on the X-axis, and I will create a ticket for it. I asked one of the developers about the grid issue and it turns out there’s already a ticket for that one (AP-11352).

Sorry for the trouble here. Thanks very much for reporting!

(EDIT: New ticket AP-15966)


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.