Problems with installation of Spotfire Nodes in KNIME 5.1

Hello Dear Community,

when installing Spotfire Nodes, I get the following error message. I try to retrieve the installation from http://update.knime.com/partner/4.7.
Does anyone else have such problems with KNIME 5.1?

Cannot complete the install because one or more required items could not be found.
Software being installed: Spotfire File Nodes 2.2.3.v202302031641 (com.tibco.ext.spotfire.feature.feature.group 2.2.3.v202302031641)
Missing requirement: Spotfire Nodes extension for KNIME Workbench 2.2.3.v202302031641 (com.tibco.spotfire.knime-nodes 2.2.3.v202302031641) requires ‘osgi.bundle; javax.ws.rs-api 2.1.0’ but it could not be found
Cannot satisfy dependency:
From: Spotfire File Nodes 2.2.3.v202302031641 (com.tibco.ext.spotfire.feature.feature.group 2.2.3.v202302031641)
To: org.eclipse.equinox.p2.iu; com.tibco.spotfire.knime-nodes [2.2.3.v202302031641,2.2.3.v202302031641]

Thanks a lot.

Svetlana

Hi @dashak,

we are in contact with the developer who scheduled some time to fix in early November.

Best regards
Steffen

1 Like

Hello Steffen,

Is early November still the expectation? I encounter the same problems.
Please see screenshot. Without the Tibco extensions my work(flows) becomes useless as Spotfire is the organisational tool via which we share our insights coming from Knime.

Many thanks in advance!

Kind regards,
Jurjen

Dear @jurjengroendijk,

I contacted the developer @andrewberridge from TIBCO Spotfire again. But I would assume that this is still the expectation.

Best regards
Steffen

Good afternoon, is there any sight of when Spotfire nodes will be available for the new version of Knime @andrewberridge ?

Many thanks for the update in advance :slight_smile:

Hello @steffen_KNIME , did you perhaps receive any update from @andrewberridge on this topic?

Many thanks in advance for keeping us posted :slight_smile:

Hi @jurjengroendijk,

unfortunately no news here.

Best regards
Steffen

That’s a pitty, these nodes are quite critical for us in connecting Knime with Spotfire.
Hopefully @steffen_KNIME will come up with some good news on a short notice :slight_smile:

Hi All,

I’m working on this in earnest right now. I will update in the next few days.

Thank you for your patience,

Andrew

2 Likes

Hi All,

An update - I’ve been fixing the nodes to work with Spotfire 14.0 LTS (recently released) and KNIME 5.x.

I have now done both, and will be releasing versions of the nodes in the coming days.

There will need to be separate versions for:

KNIME 4.6, Spotfire < 14
KNIME 4.6, Spotfire 14.0 LTS
KNIME 5.x, Spotfire < 14
KNIME 5.x, Spotfire 14.0 LTS

Thanks,

Andrew

4 Likes

Thanks a lot @andrewberridge :slight_smile:
I will ‘test’ it somewhere next week.

Dear all,

I’m delighted to announce that a new version of the Spotfire Nodes is now published! It is compatible with KNIME 5.1, 5.2 and Spotfire 12 and Spotfire 14. Note - these nodes have NOT been tested with Spotfire 11.4 (released in June 2021) but they should work. I do not currently have a Spotfire 11.4 server to test against.

There have been delays along the way due to issues with management of the dependencies with the new versions of KNIME.

However, all these should now be resolved. Please post any further issues in this thread.

You can download the new versions of the nodes from the partner update site.

Thanks,

Andrew

1 Like