Problems with KNIME Server Line Reader

Hi all,

I want to read files on the KNIME WebPortal.
So i made a FTP Connection and listed my files and let the User chose whether file thy want.
In the next step i make a Temp Dir, where these files should be stored. This directory is located in the workflow folder. In there, there are three additional path variables created, too.
First question: I want to store one of my chosen file before in one of these additional pah variables. Via the “Download”-Node it doesn’t work. Instead, it takes the path variable, sees it as a directory and saves the chosen file with its original name. Could someone help me to store my chosen file as a temp flow variable “xy.fasta”?
Right now, i “String Manipulate” my flow variable that way, that the directory is right. I transform it to an URL(looks like knime://…), so that my Line reader should work. But then i get the error message that there is not an access to the file.
I would appreciate every kind of help. Thanks!

First thing to do is ensure that the server can access loca folders. In later versions of KNIME, by default, access to the local filesystem outside of the KNIME repository is prohibited.

I can see from the screenshot that it’s trying to access /tmp/… which would explain the error message. Try setting the property as indicated in the link above, and see if that helps.

Jeff Gullick

Hi Jeff,
As you can see i do create the Temp Directory in the workflow folder. Is there any other way to go aroung this problem? Which nodes do i have to use?

Hi @mendu

can you reshare the images? Those are only internal links.

Can you also make a screenshot of the dialog of the create temp dir node?

Hi @Iris

Sorry for my mistake. Here are my screenshots.

image (1)

Hi Iris,
sorry to disturb you, but do you have any idea, how i can solve my problem?


Hi @mendu

I just tried this with my KNIME Server and it works.

Can you upload this workflow as attached to your server and execute it to see it if is working?

LineReaderonKNIMEServer.knwf (10.2 KB)