proxy problem


we are using the autoinstall.xml to reinstall major releases via ANSIBLE script. With the autoinstall.xml from version 4.7.3, I recently installed 4.8.1 and it looked like working well, until I found out that there is a problem with the proxy:
I get in the logfile a long list of repeats (5 times each) like:

System property http.proxyHost is set to “our webproxy”, but should not be set
System property http.proxyPort is set to “our port” but should not be set
System property http.proxyPort is not set but should be “our port”
…and so on…

For me this is a strange behavior, since the information is there and the server complains that the information is missing and its there.

I was able to run the KNIME on the KNIME Server (Debian) directly and in the Network preferences all looked good. After I changed from native to manual and back to native and afterwards the KNIME instance did work fine. Now I would like to fix the server. I was using a file reading node with an external file and usually only https should be used in our environment.

Do you have an idea what is going on?

Thank you!

Hi Lars,

These are messages by Eclipse, and it’s hard to pin down what they actually mean. Can you confirm that despite these messages, everything is working as expected?


Hallo Roland,

thanks for asking.

The reason why I opened the ticket is that the nodes like “File Reader” does not connect to the internet since clean installing KNIME server 4.8.1 with the autoinstall.xml from version 4.7.3 (only the workflow folder was placed back).

When I was investigating that behavior I found the posted error messages in the log file and hoped it might give you a hint what is going wrong.

Apart from that missing internet connection due to the wrong handled proxy, I do not see other misbehavior at the moment.

Hi Lars,

In that case, the problem is not with the installer. It seems the preferences that contain the proxy configuration were not added from the previous installation. Can you confirm if you did that?


The .epf file seemed to be empty in older versions as well. We were not able to find out why the server has knowledge about the right proxy settings and were it is stored and why it is not really using them.

My solution was to create a new .epf file which contained the proxy settings and now it seems to work again.

THX anyway!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.