Python Deep Learning Preferences

Hello everyone,

I created an environment in Anaconda following the instructions in the course pdf. Then I activated it to install Keras and Tensorflow; now, when I go to File>Preferences>KNIME>Python Deep Learning, I receive the message:

Library oonx_tf is not properly installed. Details: No module named ‘keras.src.engine’

How can I solve it? It seems to be a matter of version incompatibility of Keras and Tensorflow.

Thank you.

Carlos

@CarlosEnrique84 welcome to the KNIME forum. I have written down everything I know about setting up knime and deep learning here:

2 Likes

Thank you, Markus! I’ll check it!

1 Like

Hi Markus, I could install a combination of Python, Keras, TensorFlow, and Onnx packages that don’t have dependency problems. When I check the deep learning preferences in Knime, there are no error messages. However, when I try to run an LSTM or SARIMA workflow for time series analysis created by Knime, I get some errors in some nodes. Next week, I am enrolling in an instructor-led time series course, and I feel I will lose the money invested. I don’t find support for instructor-led classes. Is there any support for instructor-led courses?

The error I get is:

ERROR Keras Network Learner 4:428 Execute failed: An error occurred while creating the Keras network from its layer specifications. Details:

An error occurred while trying to launch Python: invalid syntax (, line 3)

In case Python packages are missing: you can create a new Python Conda environment that contains all packages required by the KNIME deep learning integrations in the “KNIME Deep Learning” Preferences.

This is the work flow I’m trying to execute

@CarlosEnrique84 I cannot check on a Windows machine right now. Maybe you can try and run this workflow (download the whole workflow group). Also which knime version are you using?

Also maybe you can share the yaml file you used and the conda environment propagation. Though it might take some time before I can check it out.

I fear the setup of deep learning with knime is still a challenge.

I’m writing to mention that I solved the general problem of running an LSTM workflow. The steps I followed were the following:

  1. Install community-verified Anaconda environments for Keras. KNIME and Python — Setting up Deep Learning Environments for Keras and TensorFlow | by Markus Lauber | Low Code for Data Science | Medium

  2. Copy the commands from the website and create .yaml files.

  3. Import the files into Anaconda.

  4. Update KNIME.

  5. Configure KNIME preferences in Python and Python Deep Learning to read the created environments.

  6. Run another alternative LSTM workflow. I used this Energy Demand Prediction with LSTM - Training – KNIME Community Hub and it didn’t give me an error.

In general, that is the solution. However, the initial flow never ran for me, so I think the flow configuration has a problem.

Thank you @mlauber71 !

Carlos

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.