Python importError with KNIME server but not with KNIME desktop

Hi, I’m encountering an error when I run a Python script, the error message is:
“importError: DLL load failed: %1 is not a valid win32 application”

When I run this script with KNIME desktop version, no error occurred. But when I deployed and run this script with KNIME server, returned above error. Any idea on this error? Since it goes with KNIME server, probably linked to different python configuration on KNIME server vs. desktop?

I’m using anaconda3 to create the python environment, system is windows server 2016 x64


Maybe this link helps:

They suggest rolling back anaconda to a previous stable version.
Kind regards

1 Like

thanks, will try this

Sadly I’ve come to the conclusion that conda really doesn’t do well with updating. At some point it’s often just simpler to make a reinstall. Note that you can have conda generate a yml file with your dependencies which you can then clean and use to create the environments again.

Actually it’s a good idea to have that file easily availabel so you can quickly recreate your environments.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.