Python nodes failing on parallel loop

python
#1

Hi everyone,
I have a parallel loop that has multiple python nodes creating and writing to multiple excel files. It runs without a problem on a standard loop but keeps giving me errors on parallel loop below. I manage to get it to continue by continuing the run but quite unreliable. Can anyone advise?

Execute failed: The connection attempt timed out. Please consider increasing the socket timeout using the VM option ‘-Dknime.python.connecttimeout=’.
Also make sure that the communication between KNIME and Python is not blocked by a firewall and that your hosts configuration is correct.

0 Likes

#2

Hi adjrock,

Would you mind uploading your entire knime.log file here? This could help us in finding the underlying cause of the problem. Here’s how you locate the log file. Thanks!

Marcel

0 Likes

#3

Thanks Marcel, I just had a look at the log and couldn’t see the error in question. I’m not very knowledgeable in knime log, but does the log reset if I clear the console? Also, could the error disappear if I kept running the parallel loop? I am running the workflow again today and will monitor the log and will pass it on here once I get the error again

0 Likes

#4

knime.log (12.0 KB)
Hi Marcel, I couldn’t send through the entirety of the log file due to its contents, I sent a section that I feel might contain relevant logs prior to the error

0 Likes

#5

You could try to increase the timeout setting in the KNIME.ini. This is mentioned in the log file.

-Dknime.python.connecttimeout=30000

2019-10-08 13:10:51,154 : ERROR : KNIME-Worker-1060 : Node : Python Source : 0:284:380:334:394:310 : Execute failed: The connection attempt timed out. Please consider increasing the socket timeout using the VM option ‘-Dknime.python.connecttimeout=’.
Also make sure that the communication between KNIME and Python is not blocked by a firewall and that your hosts configuration is correct.

0 Likes

#6

Sorry, do you just add this line to the ini file? Cause, I don’t have this line with any setting for Python in knime.ini

0 Likes

#7

I would just add it at the end and give it a try

0 Likes