python on knime server won't start

Hi

We are trying out KNIME Server 4.3, and have a problem getting python to start on the server. It runs when KNIME is running as the Analytic Platform. The error message from there server workflow is

There are messages for workflow "QueryProducts 2016-10-25 15.31.12"
Python Source 6:34:0:15 - ERROR: Execute failed: Could not start python kernel:
Could not detect python version

Python running interactively as the Analytic platform that is used by the server can start without a problem.

We have exported the preference file from the Analytic Platform, and placed into the config directory in the knime server workflow repository as preferences.epf. This doesn't seem to help.

We are running python 2.7 with protobuf 3.1.0.post1

David

Did you already have a look at the executor's log file on the server? Also note that the preferences.epf must be in the "config" folder of the server repository (see pages 8-9 in the administration guide).

The perference file is in the config folder of the server repository, but we hadn't look at the executor's log file, we'll take a look.

David

The log file message related to python not being found.

We rebuilt the server in the opposite order, installing python first, and then installing the knime server.

This time it works.

Could the knime server be making a record of the paths at set up? and subsequent additions to the paths aren't picked up? For reference, if this is the case, where would we find the paths configuration so that it won't be necessary to rebuild the server?

Thanks

David

I guess you are talking about the executor that runs the workflows and not the server component. But neither of those record any paths automatically. The executor looks in default locations for external executables (usually /usr/bin/ under Linux). You explicitly set the paths either in the nodes or in a preferences file provided to the executor (see the server documentation for details).