Questions about Concatenate

Dear all,

I’m sorry to keep asking you questions,

There was a problem while using Concatenate.

My data is as follows.
node1 node2
column1 column2
-1.0 -0.85
-0.98125 -0.86875
-0.9625 -0.8875
-0.94375 -0.90625
-0.925 -0.925
-0.90625 -0.94375
-0.8875 -0.9625
-0.86875 -0.98125
-0.85 -1.0

Concatenating both values removes duplicate values, leaving only 9 values remaining.

I don’t think there’s a separate option to not remove duplicate values, how can I fix it?

Thank you.

Could you explain in more detail what you’re trying to do? From your screenshot its difficult to understand what you’re trying to concatenate. Here’s info on handling duplicate RowIDs:

  • If there are duplicate RowIDs

    • Skip: Duplicate row identifiers (RowID) occurring in the second table and following tables are not appended to the output table. This option is relatively memory intensive as it needs to cache the RowIDs in order to find duplicates. Furthermore a full data duplication is needed.
    • Append suffix: The output table will contain all rows, but duplicate RowIDs are labeled with a suffix. Similar to the “Skip” option this method is also memory intensive.
    • Fail: The node will fail during execution if duplicate RowIDs are encountered. This option is efficient while checking uniqueness.

Assuming you want to concatenate the two columns, name the columns the same if you want the concatenated data in one column. With these settings, the output table is below. This is with KAP 5.2.3. The old version may look different but you need the same settings.


7 Likes

Thank you for your response.

Resolved.

Among the parts that you said

Assuming you want to concatenate the two columns, name the columns the same if you want the concatenated data in one column

I didn’t know this part.

Thank you for your explanation.

1 Like

You’re welcome. Glad I could help.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.