Quickform dialog input node precision


I am using a wrapped metanode to get double inputs from a workflow. The problem arrives when we are trying to use small numbers like “0.000225”. They appear as zero in the wrapped metanode dialog that you get when you double-click on it. Actually, if you try to give a value like that using the “Change” checkbox the “Output” value is 0.0. A “workaround” is to use scientific notation in the input, but if you open the dialog it appears as zero again (at least the output value is correct then).

Is there a way to fix this? Is there any option to change the precision there?

Thanks in advance,


Hi Borja,
Try using the Interactive View dialog of the Metanode instead of the Configuration dialog. You could access it by right-clicking on the Metanode and selecting “Execute and Open Views”. In the browser window that will show up next you may input any number and this will be saved, e.g. 1.12345678 (you don’t necessarily need to use the scientific notation). Click Close >> Apply settings temporarily >> OK . Next you could inspect the variables by right-clicking on the Metanode >> Port 1
Please find attached a workflow for the reference number_input.knwf (6.9 KB)

Hope it helps!
Best, Daria

Hello Daris,

Thanks a lot for your response! That is the workaround I found yesterday evening, but it is not so user friendly as the configuration dialog that is is easily opened with a double-click. Is there a way to open this as a bug or enhacement that could be fixed in further releases?

Hi Borja,
I agree that double-clicking is much more user-friendly if you use the workflow in the Analytics Platform. But as soon as you deploy the workflow and your users start actually testing it via the Webportal, they will only see the Interactive View.
But great spotting of the issue, thanks for raising it! I have pointed our developers to it.