R Error while updating Knime 4.5.1

Hi everyone, I just updated Knime version to 4.5.1 and now I have a problem with my R nodes since they cannot be executed

FX_Currency.knwf (33.3 KB)

The error message is “Execute failed: ‘java.lang.String org.knime.ext.r.bin.preferences.DefaultRPreferenceProvider.findPathVariableName(java.util.Map)’”

Thank you

R works for me, and I have the same R extension as you (and the same KNIME version). I can’t really interpret that error message though.

Do other R nodes also fail? Can you execute the code within the configuration window? Line-by-line?

You could give this a shot and see if that fails as well:
Generate Sequence - Node Golf Version.knwf (22.7 KB)
(it’s from this thread)

HI Thyme thank you for your response I tried the workflow but it does not work, the same message appears. It happens for all R nodes.

And when looking at the node config it looks frozen

I am going to ask the IT department to install 4.5.0 instead and see if it works, but still, it looks weird to me.

Thank you

Hmm, seems like KNIME can’t properly connect to RServe. We can still try to narrow it down.

Can you still run R itself? cmd or RStudio shouldn’t make a difference, just want to know if it still works
What version of R and RServe do you have?
Did you update those as well, or just KNIME?
Do the KNIME preferences still point to the RServe.exe, or did the upgrade to 4.5.1 mess them up?
Which KNIME version did you upgrade from?

sessionInfo() for the R version (4.0.3 for me)
packageVersion("RServe") for the RServe version ( for me)

Hi Thyme, thank you for your help, my answers below

Can you still run R itself? Yes

What version of R do you have? R version 4.1.0 (2021-05-18)

What version of RServe do you have? ‘1.8.10’ "package ‘Rserve’ was built under R version 4.1.2 "

Did you update those as well, or just KNIME? Just Knime

Do the KNIME preferences still point to the RServe.exe, or did the upgrade to 4.5.1 mess them up? Seems it is pointing properly

Which KNIME version did you upgrade from? Prettty sure it was 4.5.0

Thank you

1 Like

You could try and either upgrade R to 4.1.2 or Rserve down to 1.8.7. You could just install a fresh R version to a new directory and try to use that with KNIME.


Well, this is weird. I was hoping for an attack point. If you didn’t touch R there’s no reason to look for the cause there.

Glad that @mlauber71 is joining the fray because I’m running out of ideas. Your IT department could just reinstall the current KNIME version, maybe something went wrong with the upgrade. If you can reinstall the R extension without them, I’d try that because it’s quick.

And also the obvious “have you tried turning it off and on again?”. I know how that sounds, but it actually worked for me once.


Hi everyone thank you for your help, I downgraded the Knime version to the 4.5.0 and now is working

This is exact version


I did not touch the R versions o packages.

Thank you for your support

I guess that’s the second best outcome of that scenario, but I’m glad it’s working for you again.

1 Like

Hello everyone,

I have had exactly the same problem.

Upgraded to KNIME 4.5.1., and all R nodes upon execution gave the same error message @salazachou wrote.

Tried out installing a newer version of R, error remains.

Deinstalled KNIME installed 4.5.0. → Error is gone and I can work normally.

Cost us an hour of trial and error to get it fixed.
Maybe this is actually a bug in 4.5.1?

Best regards,

With a second case, chances of it being something else is close to 0 now. Let’s make sure this doesn’t get overlooked.

@Iris Can you notify one of your colleagues so they can look into it? I’m not sure who to summon. Thank you. :slight_smile:

1 Like

Hi @schuppius, did you had the same error message “Execute failed: ‘java.lang.String org.knime.ext.r.bin.preferences.DefaultRPreferenceProvider.findPathVariableName(java.util.Map)’” ?


1 Like

Thanks, but is weird since you already tried and worked.

I will try in my home computer, probably there is a restriction in my work computer


@Thyme from what I see there has been heavy editing in the specific parts of the R integration concerning the very path variables (to integrate the conda paths to an R installation) so I think it entirely possible that something went wrong under specific circumstances.

I was not immediately able to spot the problem. At a certain point the path gets replaced by something it should not … I see a removed blank and different PATH syntaxes …

Maybe @bwilhelm can weight in.


For what it’s worth. I’ve migrated to 4.5.1 too an my R-nodes still work as before. I’m using Windows10, own specified path to my directories containing R-3.6.3 (which is not a conda environment) and using RServe package 1.8-7.

1 Like

Yes, I did. Exactly the same.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hi everyone,
Sorry for joining the discussion so late. I am a bit puzzled how this issue only exists with 4.5.1 and not 4.5.0 because the commit in question was released with 4.5.0.

However, I would like to understand the problem to fix it. @salazachou, @schuppius, does one of you have a “stacktrace” of the error? You can find it in the KNIME log (View → Open KNIME log). I don’t see what could go wrong in this part of the code and a stacktrace would help me to locate the exact location.
Thank you!

1 Like

Hello @bwilhelm

since I have deinstalled the version that had the problem, I only have the error message “left”, and that is exactly as written by @salazachou above.

I don’t think IT will let me reinstall the newer version just for error tracing, sorry …

If there is anything apart from reinstalling that I can do, let me know!

Best regards,