R nodes not working after Uodate to 3.1

Hi,

I updated to Knime 3.1 and found that several R nodes are not working. This happens after update and after clean install on Mac as well as Windows. I have a separate R installation Version 3.2 

Regards Jerry

Hi Jerry,

can you give us some more details?

I suppose you did use the R nodes before so the basic setup stayed the same. Which nodes aren't working and do you get any error message?

Iris

Hi Jerry,

Can you install "rserve" into your KNIME installation? There were major changes in KNIME's R integration (to address scalability problems) and we are now using RServe. Error messages are apparently worth to be improved. We'll fix this ASAP, latest 3.1.1.

Can you confirm this is working?

Bernd

I have the same issue. I am using the R snippet node. Workflow worked fine in 3.01 and 2.12.2. Now gives me this error message:

 

R cannot be initialized.
Exception occured during R initialization.

 

How do i install RServe? I can't find it under the extentions.

Install Rserve inside of R i.e. install.packages("Rserve")

 

I do have Rserve installed, and here is my issue:

> library(tcltk)
+ read.table(as.character(tkgetOpenFile()), header=TRUE)
Error: [tcl] invalid command name "tk_getOpenFile".

I use tcltk to give my Rscripts within KNIME a pop-up dialog box so I can choose/save files/directories using a GUI.

I have similar code littered throughout the R scripts I use with KNIME, so this is an unfortunate problem for me.

-Brian Muchmore

Rserve is an R extension. You can install it with install.packages("Rserve", dependencies=TRUE); in an R shell.

Can anyone post a step by step guide how to use Rserve in Knime? I've installed the package Rserve, i've loaded it as a library in an R snippet, that all didnt change anything.

Hi everybody, 

to install Rserve, please close the KNIME Analytics Platfom and start R. Type in the following command:

install.packages("Rserve")

To test if your installation has succeeded, type:

library(Rserve)

If no error message appears, you can close R and launch the Analytics Platform again, the R nodes should work fine now. You do not need to load the package in the R code inside of the nodes.

If the error persists, please check your R Home paths in File > Preferences > KNIME > R. This should be the same directory of the R installation you just installed Rserve in. If you have mutliple installations of R, pay special attention to install Rserve in the correct one.

If the errror still persists, please note your operating system and system architecture (32/64 bit) below.

Greetings, Jonathan.

Okay, on Mac El Capitan the regular Rsnippet node with the simple code

matrix = as.matrix(knime.in)
data.entry(matrix)
knime.out<- data.frame(matrix)

The console shows the following error message

1:1963     Execute failed: Error in R code: "Error: unable to start data editor" 

and inside the Node (Eval Script) shows

ERROR: R evaluation failed.ERROR: assign failed

R Source (Table)  shows in the console

0:1466:1393 Execute failed: Error in R code: "Error: Paket 'zoo' konnte nicht geladen werden"

Adding Llbrary(Rserve) inside the Snippet doesn't help. What works is if I use the the RSnippet node from the Scripting section, start my R installation and run

library(Rserve); Rserve(args = "--vanilla")

Best regards

Jerry

.

I have a new error message now: Execute failed: Error in R code: "Error: java.io.IOException: Access is denied"

Windows 7 64 bit with R 3.2.0 64 bit. Same workflow works fine under 2.12.1 and 3.01

Hi MrBlond, 

could you please try creating a new R Snippet Node and execute its default script? Does the same error appear?

Thank you in advance,

Jonathan.

Hi Brian, 

library(tcltk)
read.table(as.character(tkgetOpenFile()), header=TRUE)

Seems to work fine for me on Windows 10 64-bit. Which operating system and architecture are you on?

Greetings, Jonathan.

Hi Jonathan,

That works, also some nodes which i could not execute before can now be executed. Maybe rebooting and restarting knime helped. One particular node still does not work. I've loaded these libraries in there:

library(ReporteRs)

library(ggplot2)
library(scales)
library(plyr)

Still the same error message for this node.

Best,

MrBlond

 

Thanks a lot for testing it yourself Jonathan.

I have a unique set-up since I run KNIME from within a docker container. The simple (well, not so simple when working within a docker container, but I got it to work) solution is to install the R package "rChoiceDialogs" instead of relying on package "tcltk".

-Brian

Hi Jonathan,

Any progress on the the R integration issue I have encountered?

Best,

MrBlond

We have published a couple fixes on the online update site. It's not yet an official 3.1.1 release but you can already get them into your installation by performing "File" -> "Update KNIME..."
 

I've tested the fixes. The node does seem to do more, statusses are more clearly displayed during execution. Unfortunately at the end the same error message is displayed :(

Still no fix for my R problem?

 

The strange thing is, when I open the node and execute the R code by pressing evaluate script the entire code runs without problems! However when I close the node and execute it through the GUI it gives the error message:  Execute failed: Error in R code: "Error: java.io.IOException: Access is denied"

I have the same problem, the R Snippet work ok but when I try load one package, example Library(sqlf), The console shows the following error message  "ERROR R Snippet  2:1 Execute failed: R evaluation failed."

Best regards

Andrés

 

My version is OS X YOSEMITE, Version 10.10.5

 

 

 

Dears,

I have some problems to use R in Knime on OS X.

I have the Rserve installed in R, and the path to R in Knime as "/Library/Frameworks/R.framework/Versions/3.2/Resources". I have also installed R extensions in Knime. I restarted both R and Knime, however I do not get any R node showed. Does anyone can help with this? 

Thanks

Mauro