R-snippet XLConnect error

Hi all
I’m facing the following problem with the R-snippet in KNIME. I’ve installed XLConnect severally using the R.exe console in the KNIME repository, but it still keeps showing up. My KNIME and R versions are up to date. I have installed Rserve as well
Thanks in advance

I would recommend using a standalone R version and RStudio to manage it. And you should check your versions of RServe and Cairo package:

I believe this is a XLConnect issue as opposed to a KNIME issue.

On one laptop Version 1.0.1 works for me using R 4.0.0 and KNIME. I’ve another laptop running R 3.6.3 that I tried to install XLConnect (v 1.0.3) on and it fails with the same error as you.

I briefly saw that there’s some threads elsewhere on the web talking about the same issue so I’m happy to wait for the next XLConnect version to rectify it. Since what I was trying to do could be done by the openXLSX package I used that instead.

1 Like

@mlauber71 this did not work

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.