R source node execution failed

,

Hi all,

I am using R source node for my workflow, but when I configure it it shows the following error

**ERROR:** Could not execute internal command.ERROR: R evaluation failed.: "sapply(ls(),function(a)class(get(a,envir=globalenv()))[1])"ERROR: R evaluation failed.: "sapply(ls(),function(a)class(get(a,envir=globalenv()))[1])"ERROR: eval failed

I tried to search for the error but no results were found then I looked into the KNIME forum if someone had the same error but again could not found it.

I have attached the 2 images , first image is with the error in configuration window

And the second one with the workflow where R source node stops at just 30% and did not complete the execution.
Screenshot 2020-11-05 at 16.16.51

To use the R source node I already have KNIME Interactive R Statistics Integration extension installed.

Does anyone know what is the problem here ? Your help is very much appreciated.

Thanks !

Hi @tma,

Have you followed the installation instructions for the R Integration including RServe in the correct version?

If that is the case, are you also able to run a minimal R script that does not require additional packages?

Best,
Stefan

2 Likes

You might want to explore this collection and see if you could use basic example of R and take it from there

Using R and Knime together has its challenges but it is worth it.

3 Likes