Range Slider Filter Definition quickform maximum value and number of decimal digits

The Range Slider Filter Definition quickform seems to only support 2 decimals for javascript interactive filtering.

If within node configuration, the max value of the slider is set to a range column domain max extent with more than 2 digits (e.g. 19.323), the applied filter uses only 2 digits (i.e: 19.32).
This can be seen in the web page console log looking at “Publishing interactivity event” items.
Therefore other javascript components in the page, subscribed to this filter, will always drop the rows having for range column value exactly the column domain’s max value (as 19.32 is less than 19.323, rows with 19.323 will be filtered out).
Of course it can be solved by setting the slider maximum to a value greater than range column max value, but this is a little annoying as it would require additional nodes to change the column domain.

I looked at the web page debug sources, and it seems that the view representation for the range slider quickform does not set the ‘format’ option for the noUISlider component, which therefore will use the default formatter with 2 digits.

Am I missing to set some options in quickform node configuration ?

Hi Arofab,

You can define the amount of decimal digits for the Range Slider Filter Definition quickform nod in the Slider tab. There use “Format Options” button to define the tooltips.


Hi Daria, thanks for your response,
Unfortunately even if I set the number of decimal digits in format options of Range Slider Filter Definition quickform node, the filter ecludes the row containing the maximum value.
I attach here (26.8 KB) a test workflow to better explain my issue. Just run it and see the interactive view from the wrapped node.
The filter includes the maximum value row only by extending the range column domain,

Thanks in advance

Hi Fabrizio,

see Two possible bugs in Range Slider Filter Definition node. This is a bug currently and we have created a ticket on our end.

1 Like

Thank you for informing of this issue.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.