RapidMiner Viewer node problem


#1

Hi!
I have problem with the RapidMiner Viewer node after updating KNIME (and extension pack) to version 3.6.0
It was empty ExampleSet view (at one KNIME installation) or only data with no drawing any plots (at another computer). I’m trying different releases of RapidMiner Studio at different OS (Win7 or Win10), but without success. At win10 computer it was clear installation both the KNIME and RapidMiner (not an update of previous versions), but node still not work.


#2

Hi,

I’ll try updating to RapidMiner 9, but the current stable version is based on version 5.3, so that should be installed with the report plugin to use the RapidMiner Viewer node.


#3

Hey!
RapidMiner version 5.3 was already installed. Moreover, path to RM 5.3 directly set in KNIME preferences RapidMiner section, but the changing of path no affected to node behavior. The connection KNIME-RapidMiner remain (I can see operators list and process window after Result Overview - Restore the version of the process command even after changing path).
Therefore, I mean. that the problem is in last KNIME not RM version.


#4

That should work if the 5.3 installation of RapidMiner (set in KNIME) includes the appropriate Report plugin. Otherwise the Viewer node will not work.


#5

The problem is that the RapidMiner View Node stopped work after upgrading KNIME to 3.6.0 (The RapidMiner installation stay the same, Report Extension just installed), and do not work at another computer with full clear installation of RapidMiner & KNIME.
At home computer (with not upgraded KNIME) all is ok.


#6

Thanks for reporting this problem. I can reproduce it locally, though no new problems are reported compared to KNIME 3.5, so not sure how to fix it yet.

(Interestingly not it is not reproducible with my trunk version using RM 9.0, which seems to work fine locally, but had problems creating an installable version from the nightly builds.)
I am not sure when shall I have time to fix it as my vacation comes to end tomorrow. In case the trunk bulld gets corrected, would it work for you, or you prefer the RM 5.3 version?

Edit: I still could not make the community build work, so I have uploaded my RM feature export to the pre-release link of the modified RapidMiner sources: https://github.com/aborg0/rapidminer-studio/releases/tag/20180824 (Just in case someone would like to try it: com.mind_era.knime_rapidminer.knime.feature.0.900.20180824.zip I know this is not very user-friendly way to share things, but I do not have better option now and I run out of free-time.)