RDKit 3.4.0 and Knime 3.6.2 crush

My workflow is: SDF reader --> RDKit from Molecule. When I try to visualize the output of the RDKit from Molecule node starting with this molecule, everything crushes. What I’ve noticed:
1- If I filter out the “Molecule (RDKit Mol) (RDKit Molecule)” column, the visualization after the Column Filter works fine.
2- Using Knime 3.6.0 with RDKit 3.4.0 works fine.

Any idea why?


+ 1 From my side on Ubuntu 16.04 LTS. (3.6.2 and just updated RDKit nodes to 3.4.0). I dont know which molecule exactly but I am loading in drugbank and after transformation to an RDKit column it just crashes on opening a window to view the table. No notifications or anything, it just shuts down, there is also nothing to be found in the log file.


Any molecule or specific molecules?

You could try the nightly build?

Hi swebb

Thank you for your answer. I have a problem for example with this molecule. Downloaded directly from pubchem.

Thanks for the suggestion. The nightly just crashed in a similar fashion.
I thought it might be the Molecule size, but there is no pattern. Additionally it seems not to be related to inorganic molecules + their weight.
I have about 9000 molecules so I can’t really check each one separately. If you would have a quick way to check I’ll gladly do that.


Windows 10
KNIME 3.6.2
RDKIt nodes 3.4.0.v201807311105

Can you share your KNIME log after a crash has occured?

well thats interesting.
The problem is there is nothing in the log. The crash occurred at 11:51 and the last log entry is from 11:35. I can crash it again but the log is always empty.

You could try starting knime from the terminal I suspect the command is something like

$ knime -consoleLog


$ knime.sh -consoleLog

This may print the error to the terminal prior to the crash.

I tried but nothing there I am sorry. Interestingly I can scroll the table but as soon as the RDKit column comes into view it crashes.

I’m afraid you’re going to need support from someone more familiarity with the RDKit Java integration than me.

I tried to reproduce the behavior with KNIME 3.7.2 using the RDKit Nodes 3.6.1 (nightly build) and was not able to crash KNIME - the RDKit renderer worked just fine for the sample molecule you provided. I tested on Windows 7 and Linux RedHat 6.

Is it possible that you have another molecule renderer configured as default when rendering RDKit cells? Alternatively, maybe the RDKit binaries, version 2018.09.3, that the RDKit Nodes 3.6.1 are based on, contain a fix for your issue, or other KNIME plugins that are used during rendering have been updated. Please retry with the latest build. Just checked in latest changes to the RDKit Nodes, the build should be available on May 14th, 2019.

Lets discuss the topic further in this thread, so we do not have to write the same thing twice (or is there an option to join the threads?)