RDKit not working on Windows?

Hi,

 

I recently installed Knime onto my Windows XP 64 bit Virtual Box.

I have installed the RDKit but none of the nodes will work. 

This error keeps popping up:

WARN      RDKit Add Hs                       Could not load native RDKit library: C:\Documents and Settings\Louisa\My Documents\knime_2.9.1\plugins\org.rdkit.knime.bin.win32.x86_2.3.0.201311211133\os\win32\x86\boost_system-vc100-mt-1_51.dll: Can't find dependent libraries

 

Any help is appreciated.

thanks

Louisa

It seems you are running a 32bit KNIME on a 64bit Windows. Although this combination works in principle, RDKit may need additional 32bit libraries that may not be present on your 64bit system. Please try using a 64bit KNIME instead.

When I tried to install that version previously, it didn't work, but I will try it again.

 

thanks

Could not load native RDKit library: C:\Program Files\KNIME\plugins\org.rdkit.knime.bin.win32.x86_64_4.0.1.v202002120849\os\win32\x86_64\GraphMolWrap.dll: Can’t find dependent libraries
I have installed KNIME4.3.1 64 bit in a 64 bit windows 10 pc. RDkit is not working and giving that error. i have tried re installing but its not working. please can some help

Hi @Jayb ,
This often happens because you don’t have some required libraries from Microsoft installed on your system, but it could also be something else. There is normally more information about what specifically is missing in either the knime.log file or console, can you please check there and share whatever you see?
Thanks!
-greg