read permission error in csv reader

That last bit is interesting - is KNIME being run by a user other than patrikberggren? If so, it is usual that on macOS, a user’s Downloads directory is 700 (u:rwx;o,g:-)

I don’t know, I have dowloaded and installed Knime with my user, if so that is strange…

from configuration:

hmmm - it is a total mystery what’s incorrect about you specific filesystem configuration… you could move the CSV file to someplace you know is totally readable, like /tmp/ - and if you’re bored, you can run the attached workflow to see what the JVM thinks about the file attributes at each atom of your file path…
patrik’s filesystem.knwf (11.6 KB)


Hi @patber,

did you manage to find solution? If not did you play around a bit with reading different files with different extensions from different folders with different readers (eg. File Reader or Excel Reader). Maybe you will figure it out somehow then…


It fixed it self, guess the magic solution reboot did the trick, so now that work as expected.

But now I have a new issue I wonder if you guys know how to get working, I can’t mange to read a csv for a URL, I have put in the url i the input box and as a flow variable but I get the same result, “Can’t access ‘URL’ (Read timed out)”. if I just put the URL in a browser the file downloads perfectly, how can I access a csv for A url?

I have tried both the file reader and the csv-reader nodes without success.

ended up doing it with python instead.

Hi @patber,

reboot usually works :smiley:

Regarding timeout in both nodes timeout is set to 1 sec which is pretty low. In CSV Reader there is configuration option n Settings tab to increase it. In File Reader same option is available but only via Flow Variables tab and parameter CnnectTimeoutIn…


I am seeing the exact same error on my Mac with csv reader, file reader and xls reader nodes. Any insights here? FYI, I recently updated KNIME to 4.1.2 and added the Selenium nodes as well.

1 Like

I also have a Mac and I’ve been having the same issue since I installed version 4.1.3 . I installed version 4.1.0 which fixed this issue but then I ran into other compatibility issues.

Is anyone working on a fix for this?

Screen Shot 2020-05-25 at 5.56.14 PM

Hi Ivan,

I’m working in a flow and it’s worked very well, but today I found some system upgrades and I just upgraded my extensions…and now the flow fail… It shows me the same error, Error: no read permission in input directory I try changing the folder (which is local) to another place, restart de computer…and nothing… some that I notice is the little arrow appears in the folder icon every time I try to read a folder:
Screen Shot 2020-05-25 at 15.29.15

Could you help me?

We’re trying to reproduce this issue, but it is very hard to figure out what’s actually going on. So the first step would be to rule out that this is a OS permissions problem.

Can anyone who’s experiencing this problem please confirm that KNIME has permissions to access Documents and Desktop Folders.



Hi Mark,

Thanks a lot for your help, I really appreciate it because I have to present my project tomorrow. This is how my settings looks:

Hi @IvaR,

you performed upgrade to newest version? From which one?

If that is the case you might wanna have a backup option :wink:


Hi Ivan,

The version is 4.1.0. I have the knime flow save, but in the meeting they want to see the flows run, and it doesn’t happen because the nodes don’t read the files

Do you have admin rights on your machine? Might it be an option to activate them or try with a user that has admin rights?

In my MacOS I do not see any special permissions for KNIME at all (to access the Download folder eg.). You could try and remove them (if you want to try).


Do you mean you had, previously, 4.1.0 and it was working, but then you updated (? to 4.1.3 ?) and then it stopped working? Can you install the version of KNIME which was working for you and use that version for your presentation?


I deactivated and reactivated the rights of Knime and the node started to read the files! Thanks a lot! Is a little weird because the rights was never deactivate, but its works!!!

Thank you all of you guys!



Now I have the 4.1.0 version, but that was the other option, just in case that the error was about the new upgrade, but now works so the uninstall wasn’t necessary

Thank you very much!


Hi everyone. So before reading @IvaR 's reply on deactivated and reactivated the rights of Knime, I tried to give KNIME full disk access. It also worked! I’m currently using version 4.1.3


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.