Recurrent Knime problem

Hello.

For a while, when I use Knime, this message appears about 2/3 times per hour:

'Periodic workspace save.' has encountered a problem.

Could not write metadata for '/compounds_classification'.

 

Details:

Could not write metadata for '/compounds_classification'.
/home/nico/Knime_workspace/.metadata/.plugins/org.eclipse.core.resources/.projects/compounds_classification/.markers.snap (No such file or directory)

 

compounds_classification is a workflow which is not in my workspace anymore.

 

What am I supposed to do to solve the problem?

 

Nico

I have seen a similar problem with a colleague.
The only way he was able to get rid of the problem was to export all workflows, set up a new workspace directory, and import all the workflows into the new workspace.
Not elegant, but it worked.
 

I have seen this once on my system but don't know how to reproduce the problem. If anyone has a hint on how to reliably make this heppn, plese post it here.  

A somewhat easier method to deal with this is to remove the .metadata folder in your workflow directory.  This has the same drawbacks as creating a new workspace, but without having to copy all of your workflows.

Sorry for the trouble.  Hopefully we can figure out what is causing this error and prevent it from happening in the fututre.

 

Regards,

 

Aaron  

 

 

With my colleague it started after knime crashed during a workflow-save.
That is obviously not something you can reproduce easily.

Since, I've removed the metadata folder, I don't have this problem anymore.

I tried your solution Ellert, but that didn't work in my case.

 

Thank you.

 

Nico