Regex Selection - Node: Round Double

Hello all,

I’m using Round Double Node for my workflow and here I want to include only columns which contain the word ‘Anteil’. I tried one expression in regex101 which works perfectly there but unfortunately in KNIME it doesn’t work as expected. Can someone help me with this issue. Below you find a screenshot of configuration window and the pattern I’m trying to use.

Thanks in advance.

Regards
Hm1995

Hi @hm1995

Select the Regex option:

2 Likes

Hello @hm1995
The title of your topic is about Regex Selection, however you have selected the radio button Wildcard as @ArjenEX already pointed.

The expression with ‘Wildcard’ radio button:
*Anteli

With ‘Regex’ radio button:
.*?Anteli

BR

2 Likes

Thanks @gonhaddock @ArjenEX for your reply and pointing it out. I tried it also with Regular Expression however for some reasons the other option got selected (my fault). Nevertheless it worked with the following Pattern: .*?Anteil (As suggested by: @gonhaddock )

Thanks alot

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.