Register JDBC drivers?


I’m hoping that someone can help me - I’m not technical and I’m working on my own on this.

I’ve just installed 4.3 (I was on 4.1.3, so did the full uninstall and reinstall). I am able to connect to my Microsoft SQL Server ok and can use DB Table Selector and DB Reader to draw data down, but I’m having problems using the DB Insert node. This is in workflows which worked fine before the install.

I think the problem might be that I need to re-register the JDBC drivers in Preferences=> Databases. I’ve worked out how to do most of this but I’m stuck on the Classpath.

So my questions are:

  • Do you think the JDBC driver is the issue?
  • Where can I find the classpath?
  • Also, do I need to add in JDBC parameters to the relevant tab in the Microsoft SQL Server Connector?

My database is an Azure Microsoft SLQ Server.

These are the error messages I get when I run the DB insert node:
ERROR DB Insert 0:53 Execute failed: I/O Error: Connection reset
WARN DB Insert 0:53 Node configuration was aborted after 3 seconds. To change the timeout parameter ‘Retrieve in configure timeout’ go to the ‘Advanced’ tab of the database connector node.

Any help is much appreciated.

Kind regards,


Hello @kate-rudd,

don’t think you need to register JDBC driver but rather install official Microsoft SQL Server driver to work with Azure. See here:


Thanks so much! I think I was muddling myself by reading technical docs. I needed someone to give me a direction like that.


1 Like

Hello @kate-rudd,

you are welcome. Actually last time you found that topic on your own :wink: