removing zeros after Missing Value Node process

I need to remove the “0” zeros from the output table after performing the Missing Value Node removal of "?’ placed into all tables.

I concatenated many tables and essentially any time there’s a blank cell KNIME places the infamous “?” symbol. Using the “Missing Value” Node to clear “?” from the text cells (string cells) works fine. But the Node forces me to replace blank integer cells with a zero “0”.

I cannot figure out a way to clear these zeros and their associated comma separating them from the numeric identifiers I am using. Please see the events and results graphically attached here.

thanks





Hi @creedsmith,

I don’t know your settings for the GroupBy node but you could you let your missing values for numbers untouched - setting Do Nothing in your Missing Value node for the integers.
In your GroupBy node don’t tick the Missing field in your Unique concatenate aggregation for this number column.

Best Regards
Andrew

1 Like

Hi Andrew, when I set the Missing Value Node to “Do Nothing” the question marks all reappear on my output (attached).

I will investigate your GroupBy suggestion next.

Thanks!

Andrew, I’m back after trying several of your ideas. I tried un-ticking the GroupBy “missing” boxes–first using “do nothing” in the Missing Value Node and end up with “?” everywhere again–then with the prior zeros in place–and just end up with 0’s everywhere. I just can’t seem to clear the situation of either ? or 0 after using the Missing Value Node. Thanks!!
temp1|690x362

Hi @creedsmith,

when I look at your previous pictures, I interpret your task as having several identical entries in your ListingID column. These should be grouped and the other columns should be combined (Aggregation Unique concatenate). You do not want to have any zeros or empty strings (leading comma, leading 0).

If this is the case, then exchange the GroupBy node with the Missing Value node. Group as before and do not tick the Missing field. If you want to keep the original names of the columns, then select Keep original name(s) as Column naming.
Then replace all missing values with an empty string.

Maybe this helps.

Best Regards
Andrew

1 Like

My Dearest Andrew, within my authority at KNIME I now bestow upon you the KNIME GENIUS Award for solving my problem :slight_smile: :smiley: (graphics attached). Switching the order of the NODES worked.

For anyone needing to remove the question marks “?” within KNIME outputs, particularly those in the integer cells, and wish to leave both String and Integer cells blank (if that’s what your original data had) after using the MISSING VALUE Node, please be sure to read these messages, note the order of the Nodes, and the individual Node settings.

Thank you Andrew.




2 Likes