REST nodes missing

I just upgraded my Knime SDK to 3.2 to take advantage of the new REST nodes, but I cannot seem to find them. The new features within Knime Labs are there; however, no REST nodes.  Eclipse installation details says that they are there:

  KNIME REST Client Extension    3.2.0.v201607070906    org.knime.features.rest.feature.group    KNIME GmbH, Konstanz, Germany

Any ideas how to make them appear in my node repository?

Thanks

Interesting. I have downloaded KNIME 3.2 and installed the REST extension. The nodes are available in the KNIME Labs | REST Web Services category (GET Request, POST Request, PUT Request, DELETE Request). Were there problems during the update?

I have the same issue with 3.2 knime client. KNIME Rest nodes installed but can't see them. Note that this installation was upgraded vom 3.1 with the KREST nodes.

Looks like everyone having problems with those have upgraded KNIME from a previous version. It may definitely be something upgrade related. It would be worth trying from a fresh 3.2 installation and see if the nodes become visible.

Cheers,
Marco.

Hi Guys,

this seems to be a new eclipse problem.

Could you add the clean argument in your knime.ini (in your installation directory) and restart knime?

For the SDK you would need to add the -clean argument to your start parameters.

Best, Iris

Continue to have this problem.

KNIME 3.2.1

-------------------------------

Knime AP Installation Details:

KNIME REST Client Extension    

3.2.2.v201609201941    org.knime.features.rest.feature.group    KNIME GmbH, Konstanz, Germany

 

making the query and the semantic web in the workflow
invokes the message:

Errors during load due to missing nodes (GET Request). Do you want to search and install the require extensions?


repeat
"Any ideas how to make them Appear in my node repository?"

 

Thanks

I upgraded KNIME Analytics Platform to 3.4 and now the GET Request node is missing. The error when I loaded my workflow:

********************************************************************************

*** Welcome to the KNIME Analytics Platform v3.4.0.v201707101013 ***

*** Copyright by KNIME GmbH, Konstanz, Germany ***

********************************************************************************

Log file is located at: xxxxxxxxxx\.metadata\knime\knime.log
ERROR LoadWorkflowRunnable Status: Error: Node "GET Request" not available from extension "KNIME REST Client Extension" (provided by "KNIME GmbH, Konstanz, Germany"; plugin "org.knime.rest" is not installed)

The funny thing is when I let KNIME find the missing extension, it came back with this:

Cannot complete the request.  See the error log for details.
"KNIME REST Client Extension" will be ignored because it is already installed.

I verified that it is indeed installed!  I tried to uninstall this extension, restart KNIME, install the extension, restart KNIME - it didn't help.

Any idea?

 

I have the same problem as adityatw. Adding clean to KNIME.ini doesn't solve the problem.

Message in error log is

No repository found at http://update.knime.org/store/3.4/misc/3.4/3.3.0/.

On the last message: This Update Site URL is invalid. How did it resolve to ".../3.4/3.3.0"? Can we somehow reproduce it?

And on the main problem, i.e. why the REST nodes won't load: We have a suspicion. Could you try to uninstall the social media connector nodes (twitter and google API)? These extension contribute some conflicting package which may cause the REST and JSON nodes not to load.

Please also note that we have provided the fix for 3.3.2 last week (https://tech.knime.org/changelog-v33 - AP-7683), which was released after 3.4.0. The fix will also be part of 3.4.1.

Hope this helps,
 Bernd

I have deinstalled the twitter/google nodes. Now I can select and assign a GET Request node to a workflow, but if I load an existing workflow I still get a missing get request

Error: Node "GET Resource" not available (provided by "Cenix Bioscience"; plugin "com.cenix.krest.nodes" is not installed)

About the url problem: in Preferences Install/Update the following paths are activated

Hi,

this is a different problem. We released our own version of REST nodes. However you seem to still use the old KREST nodes in your workflows. Those nodes are no longer maintained and also not supported. They were provided as a community contribution which is no longer active.

You need to exchange them with the new version of REST nodes. They support all of the previous functionality and more.

Best regards, Iris 

The issue came back when updating knime from 3.6 to 3.6.1

1 Like

@cosimotoma we were discussing different problems here, could you describe what you are currently experiencing?

Best Iris

The res nodes are missing from repository, but they appear as installed, and when i try to open an old workflow with some rest nodes it says that they are missing.
When the software tries to find them from repository it says that it cannot procede to installation because there is already installed a version

1 Like

Hallo Cosimotoma,
I have the same problem with KNIME3.6.1 I installed REST nodes but the repository do not see them and workflow working last week do not upload anymore correctly. KNIME keeps on asking to download the missing nodes but it cannot be done as the nodes are there.
-clean option in knime.ini already in use.
Best
Andrea