Rprofile file ignored

Dear all,

R scripting nodes ignore .Rprofile file located in the R home directory since R is started using the vanilla argument (tested based on this thread). Is this possible to adjust this behavior or to set things elsewhere?

We have problem with the X11 type being the default Xlib after the R building from the source. We would like to change it to cairo and .Rprofile file works for us when the R is started from the console. But it is ignored from withing the KNIME as mentioned above.

System specs: Ubuntu 20.04, KNIME 4.5.1 (4.5.2 behaves the same), latest R integration, R 4.1.3 build from the source inside the docker image

Thank you for any idea on how to make it work!

David

Hi David,

Have you tried adding the options directly to R_HOME/etc/Rprofile.site ?
That seems to work in my windows setup.

Best regards,
Temesgen

1 Like

Hi Temesgen,

thanks a lot for your hint! It was not working in the docker container running ubuntu 20.04 though.

I have solved it by other means (R build phase) so it is no longer needed on my side and X11 is set to cairo as expected.

But I would still like to know whether there is any way how to achieve this in linux if anyone has a way to go.

Thanks again!

Best regards,
David